Bug 1982699 - qmake6 generated Makefile introduces standard rpath
Summary: qmake6 generated Makefile introduces standard rpath
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt6-qtbase
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-15 13:34 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2021-09-24 20:18 UTC (History)
2 users (show)

Fixed In Version: qt6-qtbase-6.1.2-2.fc34 qt6-qtbase-6.1.2-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-15 18:19:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2021-07-15 13:34:32 UTC
Description of problem:
The Makefile generated by qmake6 contains -rpath in LFLAGS.

Version-Release number of selected component (if applicable):
qt6-qtbase-6.1.1-1.fc35

How reproducible:
Always

Steps to Reproduce:
1. $ cat > configure_non_gui.pro << EOF
QT = core

HEADERS = configure.h
SOURCES = configure.cpp
EOF
2. $ touch configure.cpp configure.h
3. $ qmake6 -makefile -nocache configure_non_gui.pro
4. $ grep ^LFLAGS Makefile 

Actual results:
LFLAGS        = -Wl,-O1 -Wl,-rpath,/usr/lib64

Expected results:
LFLAGS        = -Wl,-O1

Additional info:
This is breaking mkvtoolnix build with Qt6 due to https://fedoraproject.org/wiki/Changes/Broken_RPATH_will_fail_rpmbuild .

Comment 1 Ben Cotton 2021-08-10 13:13:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 2 Dominik 'Rathann' Mierzejewski 2021-09-06 19:03:13 UTC
Ping?

Comment 3 Jan Grulich 2021-09-06 19:10:48 UTC
Looks that using "-DQT_DISABLE_RPATH=TRUE" doesn't take any effect and we have to build with "-DQT_FEATURE_rpath=OFF". I will fix it.

Comment 4 Fedora Update System 2021-09-07 16:54:14 UTC
FEDORA-2021-cb01d209eb has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-cb01d209eb

Comment 5 Fedora Update System 2021-09-07 22:25:13 UTC
FEDORA-2021-cb01d209eb has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-cb01d209eb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-cb01d209eb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-09-08 15:18:29 UTC
FEDORA-2021-053e24d643 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-053e24d643`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-053e24d643

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-09-15 18:19:53 UTC
FEDORA-2021-053e24d643 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-09-24 20:18:11 UTC
FEDORA-2021-cb01d209eb has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.