Bug 198325 - [indic] ibus-m17n should show keymap layout image or text
[indic] ibus-m17n should show keymap layout image or text
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: FutureFeature, i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 01:11 EDT by Mayank Jain
Modified: 2009-05-06 02:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 02:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
python script to generate the array (1.11 KB, text/x-python)
2006-07-11 01:16 EDT, Mayank Jain
no flags Details
output of the script (1.32 KB, text/plain)
2006-07-11 04:55 EDT, Mayank Jain
no flags Details
A sample screenshot of the app I'm working on... (46.31 KB, image/png)
2006-12-22 02:13 EST, Mayank Jain
no flags Details
A pre-pre-alpha+buggy version :) (4.95 KB, application/octet-stream)
2006-12-22 02:17 EST, Mayank Jain
no flags Details
Latest version (60.39 KB, image/jpeg)
2007-03-05 06:43 EST, Mayank Jain
no flags Details
Latest tarball for mapper (13.38 KB, application/octet-stream)
2007-03-06 01:07 EST, Mayank Jain
no flags Details
Mapper - working tarball (3.44 KB, application/octet-stream)
2007-03-07 10:32 EST, Mayank Jain
no flags Details
SCIM tab image (3.43 KB, image/png)
2008-02-29 02:56 EST, Ani Peter
no flags Details
Inscript keyboard layout image (57.08 KB, image/png)
2008-02-29 02:58 EST, Ani Peter
no flags Details

  None (edit)
Description Mayank Jain 2006-07-11 01:11:07 EDT
Description of problem:
The key summary in m17n-db should have a table or an image describing the keymapping

Steps to Reproduce:
1. Activate SCIM by ctrl+space
2. select any language
3. click on red (?) button to activate help dialog box
  
Actual results:
Dialog box with general help

Expected results:
The keybindings can be displayed
Comment 1 Mayank Jain 2006-07-11 01:16:38 EDT
Created attachment 132218 [details]
python script to generate the array

run script as
$ ./pre.py or-inscript.mim

It will generate a file named or-inscript.h that can be included in the
program.
Comment 2 Mayank Jain 2006-07-11 01:17:51 EDT
jensp, can you please have a look at the script [& specially the output] & let
me know if this is of any help or needs to be changed?

Thanks,
Mayank
Comment 3 Jens Petersen 2006-07-11 03:20:44 EDT
How do you want to use the script?  To generate the help string?

In the longer term it would be good to implement it in scim-m17n I think
so it generate an onscreen keyboard or at least a keyboard layout image.
Comment 4 Mayank Jain 2006-07-11 04:55:39 EDT
Created attachment 132222 [details]
output of the script

Jensp, this is the file which is produced by this script.
Can this be used in the program? Either to generate an image using pango or in
some other way?
Comment 5 Mayank Jain 2006-07-11 04:57:10 EDT
This script just scans for all ("" "") & strips them of ( and ) & puts the rest
into an array.
Comment 6 Jens Petersen 2006-07-11 05:13:04 EDT
The script is fine for generating static docs, but I don't think it
is acceptable to run it at runtime from scim-m17n say: it should be
reimplemented later in C++.
Comment 7 Mayank Jain 2006-07-11 05:32:25 EDT
Jensp, lets forget the .h file for a sec. If this script can generate a png
image for the keyboard, & if we can run it in the post-processing stage of an
rpm install, it will then automatically create the image in a specified
directory when the user installs/updates his m17n-lang* package. The SCIM code
can then pick up the image & render it in the help.
Comment 8 Jens Petersen 2006-07-11 07:33:59 EDT
That certainly sounds useful.  Of course it is possible for different
users to use different xkb layouts in principle so it is not perfect
but it would be a good start and should cover the most common case for Indic
at least I guess.

I think this is too late for fc6 now, so it should be considered a possible
feature for fc7.  It would be good to discuss it upstream on scim-devel too.
Comment 9 Mayank Jain 2006-07-20 07:10:37 EDT
Jens, just remembered that GTK supports hyperlinks.
Run gtk-demo & scroll to text-widgets & see the hyperlink demo

:)
Mayank
Comment 10 Jens Petersen 2006-08-01 05:27:32 EDT
Right using tags and then forking a child process to run htmlview say should work
ok. Though there really ought to be a higher-level interface for this in gtk IMHO.
Comment 11 Mayank Jain 2006-12-22 02:13:35 EST
Created attachment 144255 [details]
A sample screenshot of the app I'm working on...
Comment 12 Mayank Jain 2006-12-22 02:17:13 EST
Created attachment 144256 [details]
A pre-pre-alpha+buggy version :)
Comment 13 Mayank Jain 2007-03-05 06:43:27 EST
Created attachment 149256 [details]
Latest version

list displaying keymaps is implemented
re-wrote parser for *.mim files
ironed out a few bugs!
Comment 14 Mayank Jain 2007-03-06 01:07:15 EST
Created attachment 149321 [details]
Latest tarball for mapper
Comment 15 Mayank Jain 2007-03-07 10:32:59 EST
Created attachment 149458 [details]
Mapper - working tarball

http://www.makuchaku.info/blog/mapper-still-hackish
Comment 16 Red Hat Bugzilla 2007-05-13 21:21:37 EDT
User majain@redhat.com's account has been closed
Comment 17 Jens Petersen 2007-05-23 22:13:24 EDT
reassigning to Parag, the new package owner
Comment 20 Ani Peter 2008-02-29 00:55:18 EST
Dear Jensp, Parag,
Since one month, I am collecting feedback from  users on the User Testability.
Had conducted a workshop for the same and some feedbacks and suggestions
obtained during workshop is mentioned in : 
http://xanadu.pnq.redhat.com/projects/engindia/wiki/UserTestabilityWorkshop

My thoughts on the keyboard layout issue:

1.On the SCIM tab appearing on the down right corner, we have the SCIM setup
tool, inscript/itrans or any other keyboard selection, an alphabet that can be
clicked and then the Help file. 

2.Can we have the respective keyboard layout images available on clicking on
this alphabet (In Malayalam its 'ക')?

3.Understand this particular option is defined for input mode in CJK locales.
But since this is free and not in use for any Indic languages, hence maybe we
can provide the keyboard layout images for Indic languages on this option.

4.Again, there are two options on the SCIM tab, which provides the same result
for setting up SCIM tool. Why do we need to have this duplication, instead we
can provide other information related to languages here, eg: we can provide the
Localised SCIM help file in this option.

Above mentioned are my ideas and thoughts which I think will make our system
more user-friendly for a very normal user with no technical knowledge or any
experiences.

Best regards
Ani
Comment 21 Jens Petersen 2008-02-29 02:10:06 EST
Thanks, Ani

(In reply to comment #20)
> http://xanadu.pnq.redhat.com/projects/engindia/wiki/UserTestabilityWorkshop

That's good.  This kind of information is valuable.
I agree our documentation is poor.  There are notes on activating
SCIM in the relnotes but that is about it, and I agree it is not
obvious.  We have now an International Language Guide
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/en-US/Internationalization_Guide/Writing_Asian_and_Indic_Languages-How_to_write_in_Indic_Languages.html
(I don't know if it has been translated yet) which helps too.

I guess better documentation in the community and on fedoraproject.org
would help too.

> 2.Can we have the respective keyboard layout images available on clicking on
> this alphabet (In Malayalam its 'ക')?

Parag is developing a map viewer utility now, so it would be good to
integrate to SCIM.

> 3.Understand this particular option is defined for input mode in CJK locales.

Which option sorry?

> But since this is free and not in use for any Indic languages, hence maybe we
> can provide the keyboard layout images for Indic languages on this option.

The problem with images is they have to be updated every time the maps
changes.  So I think it better to generate a view of the map dynamically.

> 4.Again, there are two options on the SCIM tab, which provides the same result
> for setting up SCIM tool. Why do we need to have this duplication, instead we
> can provide other information related to languages here, eg: we can provide the
> Localised SCIM help file in this option.

Yeah probably we could add a button to the input map viewer for scim-m17n.

> Above mentioned are my ideas and thoughts which I think will make our system
> more user-friendly for a very normal user with no technical knowledge or any
> experiences.

Thanks for your input and feedback.
Comment 22 Ani Peter 2008-02-29 02:56:39 EST
Created attachment 296312 [details]
SCIM tab image

Hi Jensp,

Thanks a lot for your prompt response.

I am aware about the Internationalisation Guide. But how can we expect and ask
a very normal user to go through all these manuals? I do not feel anyone would
do such an adventure going to the redhat manual web page and check for such
guides. I agree that must be read, but let that be there. Instead, why dont we
think about an option for a help which would be very handy for the user. A help
which is available on the screen, while he is working or trying to input
anything. A ready information/help/guideline on how to activate SCIM to input
any local language is very much important to have when the user opens an
application for input, as even though he logins in his native locale, he must
activate the SCIM for any input and to switch to English locale he has to
deactivate SCIM.

Keyboard layouts:
Please find attached the image of SCIM tab for Malayalam inscript so that I can
explain my idea better :)
The third option on the tab with a 'ക' sign on it. For CJK, I guess they are
defined for the input mode. In all Indic languages this option, which is
clickable is free. What I meant is, to obtain the Inscript keyboard layout
(attached) on this click.

As the fifth option we have the SCIM help file. First and fourth option gives
the same result and as this is duplication, we can provide some other
information in here.

Thanks
Ani
Comment 23 Ani Peter 2008-02-29 02:58:00 EST
Created attachment 296313 [details]
Inscript keyboard layout image

The inscript keyboard layout image
Comment 24 Jens Petersen 2008-03-04 06:02:23 EST
(In reply to comment #22)
> Please find attached the image of SCIM tab for Malayalam inscript so that I can
> explain my idea better :)
> The third option on the tab with a 'ക' sign on it. For CJK, I guess they are
> defined for the input mode. In all Indic languages this option, which is
> clickable is free. What I meant is, to obtain the Inscript keyboard layout
> (attached) on this click.

So actually Parag is working now on hopefully adding a button on the toolbar 
for scim-m17n to bring up a window with the keyboard layout visible.
Comment 25 Tony Fu 2008-09-09 23:13:50 EDT
requested by Jens Petersen (#27995)
Comment 26 Parag Nemade 2009-05-06 02:22:45 EDT
As we got now ibus as default Input Method, moving this to ibus-m17n and changing summary.
Also, we have got fix for this bug in ibus-m17n-1.1.0.20090211-4.fc11

Note You need to log in before you can comment on or make changes to this bug.