Bug 198338 - gnome-mount crashes on dvd insertion
gnome-mount crashes on dvd insertion
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 04:41 EDT by Brian Chadwick
Modified: 2013-03-05 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:06:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Chadwick 2006-07-11 04:41:39 EDT
Description of problem:


Version-Release number of selected component (if applicable):
0.4

How reproducible:
everytime

Steps to Reproduce:
1.insert dvd
2.
3.
  
Actual results:
"gnome-mount has quit unexpectedly"

Expected results:
just mount the dvd and display a desktop icon

Additional info:

mount -t iso9660 /dev/hdd /mnt/dvd work just dandy. This bug has been listed for
some time.... gnome-live-disk has this working ... surely fedora can fix it
sometime soon
Comment 1 Brian Chadwick 2006-07-11 04:43:05 EDT
please fix this soon .... i am having all sorts of support calls for this bug
and it should be easy to fix ... surely
Comment 2 Brian Chadwick 2006-08-08 07:55:47 EDT
johnp@redhat.com you must be scratching you rhead over this .... some people
have this problem ... most people dont ... here is my results ...

I have a sony ddu-1611 dvd-rom ... firmware revisdion 1.0. I tried Ubuntu .. it
managed to mount the drive  (with a DVD in it not a CD) . . but it decided it
was a usbdisk ... yes ... i thought that too .... so i investigated further,
being pretty sure that this is hardware related ... i reflashed the firmware in
the drive .... (this necessitated running Win XP unfortunately) ... now it works
perfectly ... 

I want to help .... can I send you anything from wotever is unhappy that you may
want to use in future for compatibilty? .. please tell me wot to send .... 


cheers and beers

Brian
Comment 3 John (J5) Palmieri 2006-08-08 11:10:34 EDT
David,

So this looks like a hardware issue though there might be something HAL or
gnome-mount can do so it doesn't crash or even works around the issue.
Comment 4 David Zeuthen 2006-08-08 12:12:57 EDT
can people experiencing this problem try the gnome-mount package from rawhide on
FC5? You probably need to "rpmbuild --rebuild" the SRPM... 

if it works, it's worth considering upgrading gnome-mount in FC5 also because
the gnome-mount is FC5 is terribly feature incomplete.
Comment 5 Brian Chadwick 2006-08-08 22:16:10 EDT
i would help if I could ... but now that i flashed the drive with the latest
firmware, there is no way back ... i cant find the orginal firmware
anywhere...for what its worth it was a Sony DDU-1611 DVD-ROM firmware version
GYS1 .. this drive is in fact can OEM Lite-on LTP-163 ... which i reflashed to
firmware version GDHJ.

if i caome across the old firmware i will flash it back and test the new
gnome-mount in raw-hide

I dont know if this helps ... but even ubuntu had a prob with this drive .. it
would automount as "usbdisk" and dissapear from the CDROM hardware list ... go
figure :)
Comment 6 David Zeuthen 2006-08-09 09:04:50 EDT
Does the drive work as expected with the new firmware?
Comment 7 Brian Chadwick 2006-08-09 18:21:56 EDT
David,

The drive now functions perfectly with FC5 (both out of the box and updated).
Interestingly, Ubuntu's gnome-mount was able to mount the drive before it was
flashed, but it mounted it as /media/usbdisk ??? ... whereas FC5 gnome-mount
crashed. Maybe there is a clue there. I have an output from lshal (on paper only
unfortunately) but nothing stands out to me. You are welcome to a jpg of that
output and also of the current output with the new firmware.

Brian
Comment 8 Bug Zapper 2008-04-03 23:17:12 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Bug Zapper 2008-05-06 12:06:31 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.