Bug 19835 - lilo fails to use bios= for raid1 disks
lilo fails to use bios= for raid1 disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: lilo (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-25 19:52 EDT by Michael Tokarev
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-25 19:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Tokarev 2000-10-25 19:52:37 EDT
I have a situation where I was forced to insert my bootdisks with
softraid-1 root to another machine for repairing, and need to reinstall
lilo on that disks.  If that will be just one disk w/o raid, my steps
will be to create temporary lilo.conf with entries like this:

  disk=/dev/sdc
  bios=0x80
  boot=/dev/sdc
  ...

and all will be just fine, installed this way lilo will boot when
sdc becomes sda on original machine.  So far, so good.  Now I have
things complicated by raid:

  boot=/dev/md1 # set up on /dev/sdc1 and /dev/sdd1
  disk=/dev/sdc
  bios=0x80
  disk=/dev/sdd
  bios=0x81
  ...

When I run lilo with this config, it complains:

------
# lilo -v -v -t -r /x -C /etc/lilo.conf.tmp
LILO version 21.4-4 (test mode), Copyright (C) 1992-1998 Werner Almesberger
'lba32' extensions Copyright (C) 1999,2000 John Coffman

boot = /dev/sdc, map = /boot/map.0821
Reading boot sector from /dev/sdc
Merging with /boot/boot.b
Secondary loader: 11 sectors.
Boot image: /boot/vmlinuz-2.2.16-22
Setup length is 7 sectors.
Mapped 1228 sectors.
Mapping RAM disk /boot/initrd-2.2.16-22
RAM disk: 974 sectors.
Added linux *
Map file size: 15360 bytes.
The boot sector and the map file have *NOT* been altered.
Fatal: Duplicate geometry definition for /dev/sdc
------

I really don't know if /dev/sdc is bootable after this (yes I know
about test mode, -t ;), but /dev/sdd definitely is _not_ bootable.

Maybe I'm just wrong or don't understand what I need to specify
here.  All other options leads to the same results:

  disk=/dev/sdc bios=0x80 # w/o /dev/sdd
  disk=/dev/md1 bios=0x80
  disk=/dev/sdc bios=0x80 disk=/dev/sdd bios=0x80 # the same for both
  ...
(that are one-lines that I tried -- only one line was actually
present in config).

It won't work without bios= also -- when I try to boot from such
a disk, lilo will execute endless loop displaying some hexadecimal
digits.

This was with lilo-21.4.4-10 (from 7.0 release) and some earlier
releases of 21.4.4.
Comment 1 Jeremy Katz 2002-06-04 01:23:22 EDT
This seems to be better in current releases

Note You need to log in before you can comment on or make changes to this bug.