Bug 1983505 - Unsigned addons disabled (regression from v89)
Summary: Unsigned addons disabled (regression from v89)
Keywords:
Status: CLOSED DUPLICATE of bug 1988841
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-19 02:30 UTC by Vasily Pupkin
Modified: 2021-08-04 06:45 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-04 06:45:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
yellow warning (65.29 KB, image/jpeg)
2021-07-19 02:30 UTC, Vasily Pupkin
no flags Details
red warning (60.93 KB, image/jpeg)
2021-07-19 02:30 UTC, Vasily Pupkin
no flags Details

Description Vasily Pupkin 2021-07-19 02:30:17 UTC
Created attachment 1803208 [details]
yellow warning

Created attachment 1803208 [details]
yellow warning

Created attachment 1803208 [details]
yellow warning

Description of problem:


Firefox 90 has a regression where unsigned extensions are disabled without an option to enable.

Steps to Reproduce:
1. Install firefox version 89
2. Install .xpi extension from file
3. Extension gets yellow warning "could not be verified for use in Firefox" but works
4. Upgrade to version 90
5. Extension now has red warning "could not be verified for use in Firefox and has been disabled"
6. Extension is disabled without option to enable it

Actual results:
Red warning, extension disabled

Expected results:
Yellow warning, extension enabled

Additional info:
Screenshots attached

Unsigned extensions had been disabled upstream with Fedora having a patch to allow this.
It does not seem it's in release notes either upstream or in Fedora about disabling it in v90

Comment 1 Vasily Pupkin 2021-07-19 02:30:43 UTC
Created attachment 1803209 [details]
red warning

Comment 2 Martin Stransky 2021-07-19 07:21:56 UTC
I see. I think the unsigned addons are supported by Developer edition/Nighly only right now (https://www.mozilla.org/en-US/firefox/developer/. I don't recall any updates in this area, perhaps there's some code change we didn't catch.

Comment 3 Vasily Pupkin 2021-07-19 18:47:47 UTC
gentoo bug https://bugs.gentoo.org/802285 which points to https://bugzilla.mozilla.org/show_bug.cgi?id=1712633 that caused the issue

Comment 4 fednuc 2021-08-01 15:31:17 UTC
Filed bug about adding build flags that allow system-dir. unsigned extensions, see https://bugzilla.redhat.com/show_bug.cgi?id=1988841.

Comment 5 Martin Stransky 2021-08-02 19:56:33 UTC
Will look at it this week, Thanks.

Comment 6 Martin Stransky 2021-08-04 06:45:30 UTC

*** This bug has been marked as a duplicate of bug 1988841 ***


Note You need to log in before you can comment on or make changes to this bug.