Bug 198380 - Package kexec-tools lacks IPv6 support
Package kexec-tools lacks IPv6 support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:21 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 07:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 06:21:16 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/kexec-tools-1.101/kexec/ifdown.c:38:	if ((fd = socket(AF_INET, SOCK_DGRAM, 0)) < 0) {
Comment 1 Neil Horman 2006-07-11 07:35:55 EDT
This should be ok for this package.  That function only uses a socket to set
interface flags for interface that need the IFF_UP flag cleared.  It doesn't
actually need to send/receive any network data.  This could be done more
generically with netlink or raw sockets, but at the moment IPV6 support isn't in
any way needed in this package
Comment 2 Dennis Gilmore 2006-07-11 07:43:20 EDT
I think  the idea is not that ipv6  is not needed  but that ipv6 support is 
wanted 
Comment 3 Neil Horman 2006-07-11 07:52:12 EDT
Actually it is you who is missing my point, although as I re-read my comments I
could have made them more clearly.  That socket creation refereced above uses
AF_INET to do its work, but it could just as easily use AF_INET6, AF_RAW, etc. 
The only work that socket does is to change interface flags.  It  conducts no
network communitcation at all.  As such we could change it to use a different
protocol, or add protocols over which that socket did its work, but to do so
would be pointless, since that sockets actions are protocol agnostic.

Note You need to log in before you can comment on or make changes to this bug.