Bug 198384 - Package libvirt lacks IPv6 support
Package libvirt lacks IPv6 support
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:22 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 12:07:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 06:22:04 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/libvirt-0.1.0/src/internal.h:107:    int type;               /* PF_UNIX or PF_INET */
/libvirt-0.1.0/src/xend_internal.c:923:    xend->type = PF_INET;
/libvirt-0.1.0/src/xend_internal.c:925:    xend->addr_in.sin_family = AF_INET;
Comment 1 Daniel Veillard 2006-07-11 06:29:05 EDT
I take patches, but I don't think in the case of libvirt it's is useful,
I don't expect it to be used outside an intranet.

Daniel
Comment 2 Daniel Veillard 2006-11-02 12:07:45 EST
Deferred, won't fix since I don't know know why this would matter nor how
to fix and I didn't get a patch.

Daniel

Note You need to log in before you can comment on or make changes to this bug.