Bug 198386 - Package mc lacks IPv6 support
Package mc lacks IPv6 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:22 EDT by Peter Vrabec
Modified: 2013-07-02 19:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 04:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FTP over IPv6 support (11.15 KB, patch)
2006-09-25 16:50 EDT, Daniel Kopeček
no flags Details | Diff

  None (edit)
Description Peter Vrabec 2006-07-11 06:22:41 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/mc-4.6.1a/vfs/samba/lib/netmask.c:73:	if ((fd = socket(AF_INET, SOCK_DGRAM, 0)) == -1) {
/mc-4.6.1a/vfs/samba/lib/netmask.c:172:	if ((fd = socket(AF_INET, SOCK_DGRAM, 0)) == -1) {
/mc-4.6.1a/vfs/samba/lib/netmask.c:272:	if ((fd = socket(AF_INET, SOCK_DGRAM, 0)) == -1) {
/mc-4.6.1a/vfs/samba/lib/util_sock.c:632:  out_fd = socket(AF_INET, type, 0);
/mc-4.6.1a/vfs/samba/lib/util_sock.c:643:  sock_out.sin_family = AF_INET;
/mc-4.6.1a/vfs/samba/lib/util_sock.c:739:  res = socket(PF_INET, type, 0);
/mc-4.6.1a/vfs/samba/lib/util_sock.c:749:  sock_out.sin_family = PF_INET;
/mc-4.6.1a/vfs/samba/lib/util_sock.c:836:				AF_INET)) == 0) {
/mc-4.6.1a/vfs/samba/libsmb/nmblib.c:714:  sock_out.sin_family = AF_INET;
/mc-4.6.1a/vfs/mcfs.c:37:#include <sys/socket.h>		/* AF_INET */
/mc-4.6.1a/vfs/mcfs.c:229:    server_address.sin_family = AF_INET;
/mc-4.6.1a/vfs/mcfs.c:255:    if ((my_socket = socket (AF_INET, SOCK_STREAM, 0)) < 0) {
/mc-4.6.1a/vfs/mcserv.c:862:    local_address.sin_family = AF_INET;
/mc-4.6.1a/vfs/mcserv.c:871:    if ((my_socket = socket (AF_INET, SOCK_STREAM, 0)) < 0) {
/mc-4.6.1a/vfs/mcserv.c:1041:    if (from.sin_family != AF_INET)
/mc-4.6.1a/vfs/mcserv.c:1203:    if ((sock = socket (AF_INET, SOCK_STREAM, 0)) < 0)
/mc-4.6.1a/vfs/mcserv.c:1212:    server_address.sin_family = AF_INET;
/mc-4.6.1a/vfs/ftpfs.c:60:#include <sys/socket.h>		/* AF_INET */
/mc-4.6.1a/vfs/ftpfs.c:670:    server_address.sin_family = AF_INET;
/mc-4.6.1a/vfs/ftpfs.c:691:    if ((my_socket = socket (AF_INET, SOCK_STREAM, 0)) < 0) {
Comment 1 Jindrich Novy 2006-09-05 11:17:01 EDT
After a little investigation I see that mc uses longs for storing addresses so
that significant rewrite of the noticed VFS bits (samba, fish, mcfs, ftp) is
needed. Since mc is mostly a filemanager used to manage local files in 95% of
the time I think it won't affect FC6/RHEL5 in a significant way if we ship it in
the current state.
Comment 2 Daniel Kopeček 2006-09-25 16:50:28 EDT
Created attachment 137087 [details]
FTP over IPv6 support

This patch is only for ftpfs. Mc has some more vfses that need ipv6 support.
But ftp has the highest priority imho, so I'm sending it now. smbfs will be the
next :]
Comment 3 Jindrich Novy 2006-09-26 04:48:53 EDT
Applied after few tune-ups. Thanks.

Note You need to log in before you can comment on or make changes to this bug.