Bug 198393 - Package nss_db lacks IPv6 support
Summary: Package nss_db lacks IPv6 support
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_db (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: IPv6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-07-11 10:24 UTC by Peter Vrabec
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 13:58:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Vrabec 2006-07-11 10:24:44 UTC
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:310:	if ((s = socket(AF_INET, SOCK_STREAM, proto->p_proto)) < 0)
/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:314:	si.sin_family = AF_INET;
/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:402:	if ((s = socket(AF_INET, SOCK_STREAM, proto->p_proto)) < 0)
/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:406:	si.sin_family = AF_INET;
/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:459:	if ((s = socket(AF_INET, SOCK_STREAM, proto->p_proto)) < 0)
/db-4.3.28/examples_c/ex_repquote/ex_rq_net.c:474:	si.sin_family = AF_INET;

Comment 1 Nalin Dahyabhai 2006-07-11 13:58:23 UTC
This looks like an invalid report -- the nss_db module doesn't call into the
example code which comes bundled with copy of libdb which we embed.


Note You need to log in before you can comment on or make changes to this bug.