Bug 198396 - Package openobex lacks IPv6 support
Package openobex lacks IPv6 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openobex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:25 EDT by Peter Vrabec
Modified: 2015-02-01 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 05:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtogami: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 06:25:43 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/openobex-1.2/lib/inobex.c:61:	self->trans.peer.inet.sin_family = AF_INET;
/openobex-1.2/lib/inobex.c:74:	self->trans.self.inet.sin_family = AF_INET;
/openobex-1.2/lib/inobex.c:89:	self->serverfd = obex_create_socket(self, AF_INET);
/openobex-1.2/lib/inobex.c:148:	self->fd = obex_create_socket(self, AF_INET);
/openobex-1.2/lib/inobex.c:153:	self->trans.peer.inet.sin_family = AF_INET;
Comment 1 Jiri Moskovcak 2007-08-28 09:59:03 EDT
Package Change Request
======================
Package Name: openobex
Updated Fedora Owners: jmoskovc@redhat.com
Comment 2 Warren Togami 2007-08-28 14:44:29 EDT
CVS seems to be already done
Comment 3 Jiri Moskovcak 2007-08-29 05:09:14 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.