Bug 198417 - Package vim lacks IPv6 support
Package vim lacks IPv6 support
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 06:31 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 09:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to remove IPv4 specific code from integration and netbeans in vim (6.75 KB, patch)
2006-07-11 08:29 EDT, Jan Pazdziora
no flags Details | Diff

  None (edit)
Description Peter Vrabec 2006-07-11 06:31:01 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines: 

/vim70/src/netbeans.c:324:    if ((sd = (NBSOCK)socket(AF_INET, SOCK_STREAM, 0)) == (NBSOCK)-1)
/vim70/src/netbeans.c:333:    server.sin_family = AF_INET;
/vim70/src/netbeans.c:366:	    if ((sd = (NBSOCK)socket(AF_INET, SOCK_STREAM, 0)) == (NBSOCK)-1)
/vim70/src/integration.c:656:	if ((sd = socket(AF_INET, SOCK_STREAM, 0)) == -1) {
/vim70/src/integration.c:664:	server.sin_family = AF_INET;
/vim70/src/integration.c:686:			if ((sd = socket(AF_INET, SOCK_STREAM, 0)) == -1) {
Comment 1 Jan Pazdziora 2006-07-11 08:29:33 EDT
Created attachment 132232 [details]
Patch to remove IPv4 specific code from integration and netbeans in vim

Please consider the attached patch.

I did not test the patch beyond compile. Also note that with the getaddrinfo
approach, there are multiple socket and connect calls caused by multiple values
returned, which adds to the 36 retries in the original code. Maybe the number
of retries might need to be reconsidered? Please take the patch only as a hint
of how the code might need to change.
Comment 2 Karsten Hopp 2006-08-03 09:58:48 EDT
workshop and netbeans stuff is currently disabled in FC-devel, all those F_INET
matches from the original report aren't in use in our vim package.
I'll notify upstream of the proposed patch, but it definitely needs some more work
p.e. as it doesn't patch autofoo stuff for --enable-ipv6/--disable-ipv6

Note You need to log in before you can comment on or make changes to this bug.