Bug 1984319 (CVE-2021-3246) - CVE-2021-3246 libsndfile: Heap buffer overflow via crafted WAV file allows arbitrary code execution
Summary: CVE-2021-3246 libsndfile: Heap buffer overflow via crafted WAV file allows ar...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-3246
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1985029 1984320 1985024 1985025 1985026 1985027 1985028
Blocks: 1984322
TreeView+ depends on / blocked
 
Reported: 2021-07-21 09:04 UTC by Marian Rehak
Modified: 2021-08-30 09:21 UTC (History)
2 users (show)

Fixed In Version: libsndfile 1.0.28
Doc Type: If docs needed, set a value
Doc Text:
A heap buffer overflow flaw was found in libsndfile. This flaw allows an attacker to execute arbitrary code via a crafted WAV file. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-08-24 09:34:55 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:3253 0 None None None 2021-08-24 08:08:08 UTC
Red Hat Product Errata RHSA-2021:3295 0 None None None 2021-08-30 09:21:41 UTC
Red Hat Product Errata RHSA-2021:3297 0 None None None 2021-08-30 08:13:45 UTC
Red Hat Product Errata RHSA-2021:3298 0 None None None 2021-08-30 08:22:06 UTC

Description Marian Rehak 2021-07-21 09:04:17 UTC
A heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file.

Upstream Reference:

https://github.com/libsndfile/libsndfile/issues/687

Comment 1 Marian Rehak 2021-07-21 09:05:20 UTC
Created libsndfile tracking bugs for this issue:

Affects: fedora-all [bug 1984320]

Comment 5 errata-xmlrpc 2021-08-24 08:08:07 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:3253 https://access.redhat.com/errata/RHSA-2021:3253

Comment 6 Product Security DevOps Team 2021-08-24 09:34:55 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-3246

Comment 7 errata-xmlrpc 2021-08-30 08:13:44 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Extended Update Support

Via RHSA-2021:3297 https://access.redhat.com/errata/RHSA-2021:3297

Comment 8 errata-xmlrpc 2021-08-30 08:22:04 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2021:3298 https://access.redhat.com/errata/RHSA-2021:3298

Comment 9 errata-xmlrpc 2021-08-30 09:21:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2021:3295 https://access.redhat.com/errata/RHSA-2021:3295


Note You need to log in before you can comment on or make changes to this bug.