Bug 198439 - Package elilo lacks IPv6 support
Package elilo lacks IPv6 support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: elilo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 08:33 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 09:47:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 08:33:59 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
		
This package seems to lack IPv6 support.
Comment 1 Chris Lumens 2006-07-13 12:42:51 EDT
What test was performed that determined elilo lacks IPv6 support?  Can I get the
results of it?
Comment 2 Peter Vrabec 2006-07-18 05:40:53 EDT
We grep sources and search F_INET and F_INET6 macro.
$ grep -R INET *
src/lib/efi.c:    fd = socket(AF_INET, SOCK_DGRAM, 0);
src/lib/efi.c.orig:    fd = socket(AF_INET, SOCK_DGRAM, 0);

When I look at code it seems to me this bug was reported by mistake. Elilo doesn't use socket 
to send or receive date. It use it to get some driver information, so this is similar to #198380.

Close this bug if I'm right, please.
Comment 3 Chris Lumens 2006-07-18 09:47:48 EDT
Yup, that's what it looks like to me too.  Thanks for investigating.

Note You need to log in before you can comment on or make changes to this bug.