Bug 198452 - Package openoffice.org lacks IPv6 support
Package openoffice.org lacks IPv6 support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-11 08:37 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 09:14:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 35548 None None None Never

  None (edit)
Description Peter Vrabec 2006-07-11 08:37:18 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
		
This package seems to lack IPv6 support.
Comment 1 Caolan McNamara 2006-07-11 08:54:48 EDT
AFAIK 2.0 is *supposed* to be ok with IPV6, e.g. the following implementations
in key infrastructure ...

http://qa.openoffice.org/issues/show_bug.cgi?id=35548 UNO ipv6 support
http://qa.openoffice.org/issues/show_bug.cgi?id=35288 INetURL support
http://qa.openoffice.org/issues/show_bug.cgi?id=33615 webdav ipv6

what exactly doesn't work ? Or what was the trigger for this autobug ?
Comment 2 Peter Vrabec 2006-08-02 08:50:01 EDT
We greped sources and search for AF_INET or AF_INET6 macro. Since AF_INET6 was not 
found, our script filed this bug report.  Of course there are many ways how to implement IPv6, 
so the script might fail.

If you are sure IPv6 works in our Oo, close this but report. thx.
Comment 3 Caolan McNamara 2006-12-19 09:14:35 EST
Upstream (Sun) informs me that OOo is supposed to work fine with ipv6 as it
currently stands (>= 2.0.4), which isn't to say there might be no bugs in
implementation, but the support is there.
Comment 4 David Woodhouse 2006-12-20 12:00:46 EST
It's trivial to test IPv6 support. If you need assistance please ask; it's as
simple as running 'radvd' on one machine on the Ethernet segment, with a
site-local address.

I don't actually know how to test OOo's IPv4 support, so I haven't done so myself.

Note You need to log in before you can comment on or make changes to this bug.