This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 198492 - xterm wont redirect display
xterm wont redirect display
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 10:23 EDT by John Brearley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 12:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Brearley 2006-07-11 10:23:11 EDT
Description of problem:
When you try to redirect the xterm display to another computer, you get a
segmentation fault or error message "xterm xt error: cant open display: %s"

Version-Release number of selected component (if applicable):
FC5 with all latest updates from yum

How reproducible:
On demand

Steps to Reproduce:
1. Computer1, type: DISPLAY=192.168.0.101:0.0
2. Computer2, type: xhost +
3. Computer1, type: xterm &
  
Actual results:
segmentation fault or error message "xterm xt error: cant open display: %s"

Expected results:
xterm window on computer 2.

Additional info:
Computer 2 was running Red Hat 9 since RH9 allows displays to be redirected.
Fedora Core 5 has issues receiving incoming X11 displays, see bug #197964.
Comment 1 Jason Vas Dias 2006-07-13 12:03:18 EDT
I cannot reproduce this with the latest FC-5 xorg-x11-server-1.0.1-9.fc5.5 RPMs,
AFTER I had removed the default 'ServerArgsLocal=-nolisten tcp' from my 
/etc/X11/xdm/kdmrc .

I've tested displays from FC-4, FC-6, and RHEL-4 going to FC-5, and displays
from FC-5 to FC-4, FC-6, and RHEL-4, and they all work OK, once the X server
'-nolisten tcp' arg was removed and the X server restarted.

Check that your X server on FC-5 is not being run with the 'nolisten' argument:
  # ps -ef | grep nolisten

I've not been able to reproduce any xterm segmentation faults - please, if 
you experience an xterm segfault, append the core dump to this bug report :
 # ulimit -SH -c unlimited
 # xterm ...
 ( segfault, core dumped )
 # gzip core.*
and send the core.*.gz to me (jvdias@redhat.com) or append them to this bug
report, also specifying the machine architecture and the output of this command:
 # rpm -qa xterm 'xorg-*' glibc
thanks!

Note You need to log in before you can comment on or make changes to this bug.