Bug 1985081 - Downloaded log file (All task logs) contains logs of all taskrun in a single line
Summary: Downloaded log file (All task logs) contains logs of all taskrun in a single ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1985080
Blocks: 1995617
TreeView+ depends on / blocked
 
Reported: 2021-07-22 19:23 UTC by OpenShift BugZilla Robot
Modified: 2021-08-31 16:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-31 16:17:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 9596 0 None open [release-4.8] Bug 1985081: Fix Pipeline Download All 2021-07-28 16:40:08 UTC
Red Hat Product Errata RHBA-2021:3247 0 None None None 2021-08-31 16:17:39 UTC

Description OpenShift BugZilla Robot 2021-07-22 19:23:17 UTC
+++ This bug was initially created as a clone of Bug #1985080 +++

Clone of Jira ticket for backports: https://issues.redhat.com/browse/ODC-6138

Description of problem:
Downloaded log file (All task logs) contains logs of all taskrun in a single line

Prerequisites (if any, like setup, operators/versions):
Install Openshift Pipelines Operator 1.5

Steps to Reproduce
1. Create a pipeline with multiple tasks
2. Start the Pipeline
3. Once the pipelinerun execution gets completed move to logs tab and click on Download all task logs button
4. Open the downloaded file

Actual results:
Logs of all taskrun are included in a single line

Expected results:
Logs of taskruns should contain line breaks

Reproducibility (Always/Intermittent/Only Once):
Always

Build Details:
Able to reproduce this issue on 4.7 and 4.8

Reproducible on:
- 4.8.0
- 4.6.39

Additional info:
Was implemented in 4.5, will need to be back ported to 4.6 (EUS). Need to figure out when it broke so we can properly handle the backport support.

Comment 4 spathak@redhat.com 2021-08-19 09:09:02 UTC
Verified on build version: 4.8.0-0.nightly-2021-08-17-004424
Browser: Google Chrome 89

Comment 5 ximhan 2021-08-20 07:26:57 UTC
OpenShift engineering has decided to NOT ship 4.8.6 on 8/23 due to the following issue.
https://bugzilla.redhat.com/show_bug.cgi?id=1995785
All the fixes part will be now included in 4.8.7 on 8/30.

Comment 9 errata-xmlrpc 2021-08-31 16:17:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.9 bug fix), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3247


Note You need to log in before you can comment on or make changes to this bug.