Bug 198516 - need CONFIG_PNPACPI=y in ia64 config
need CONFIG_PNPACPI=y in ia64 config
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-07-11 12:09 EDT by Aron Griffis
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 17:51:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2006-07-11 12:09:28 EDT
Attempted installation on serial console fails with:
No ttyS device at MMIO 0xff5e0000 for console

This was using network boot images downloaded from
download.fedora.redhat.com/.../development/ia64/os/images on 2006-07-06.

The problem is that CONFIG_PNPACPI=y needs to be specified in the kernel config.
 This is a new requirement in 2.6.17, since the acpi components were all added
to PNP, so 8250_pnp takes over hooking up the serial ports.  As a result,
CONFIG_PNPACPI=y is needed to make the serial console available.

See also the report at
https://www.redhat.com/archives/fedora-ia64-list/2006-July/msg00001.html

diff -r 0d1ea668a7c6 devel/configs/config-ia64-generic
--- a/devel/configs/config-ia64-generic Tue Jul 11 12:15:19 2006 -0400
+++ b/devel/configs/config-ia64-generic Tue Jul 11 12:17:19 2006 -0400
@@ -135,7 +135,7 @@ CONFIG_HOTPLUG_PCI_SGI=m
 CONFIG_HOTPLUG_PCI_SGI=m
 
 CONFIG_ACPI_VIDEO=m
-# CONFIG_PNPACPI is not set
+CONFIG_PNPACPI=y
 
 # Broken in 2.6.10-bk3 for ia64 (No DMA_MODE_WRITE)
 # CONFIG_MMC_WBSD is not set
Comment 1 Prarit Bhargava 2006-07-12 09:25:38 EDT
This looks sane.  Dave, when you get a chance please commit this -- headless
installs are broken :(

P.

Note You need to log in before you can comment on or make changes to this bug.