Bug 198571 - xcalc missing from xorg-x11-apps
xcalc missing from xorg-x11-apps
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-apps (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 19:39 EDT by james
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 22:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2006-07-11 19:39:07 EDT
Description of problem:
Comparing the old xorg-x11-tools and the new xorg-x11-apps, there are several
simple utilities missing, including xcalc.  How annoying is that?  It's
annoying.  Thankfully, xeyes is returned.

Version-Release number of selected component (if applicable):
xorg-x11-apps-7.0-1



Expected results:
There is a certain tradition to respect.
Comment 1 Chris Elmquist 2006-07-19 08:00:38 EDT
It is extremely annoying!  I have been a Redhat/Fedora supporter since the first
release of RH Linux but the discovery of xcalc being removed is an extreme
disappointment and black mark against FC5.  Even if it was not Fedora's
decision to remove the application, please insist that it is restored (and
hopefully via an update) soon.  Many of us choose Linux because it is not
bloated and GUI intensive.  Forcing us to install Gnome or KDE just to have
these simple and useful utilities will send us looking elsewhere for solutions.
Comment 2 Mike A. Harris 2006-07-19 19:15:43 EDT
Hi guys,

There are a number of applications and utilities which were formerly part
of the monolithic X Window System package, which are now maintained and
released as individual tarballs upstream.  Some of these applications and
utilities are essential to the operation of the X Window system, and
remain in the base operating system (Fedora Core).  The remainder of the
apps/utils were intended to be shipped as part of Fedora Extras, however
that hasn't occurred yet.

I've got a list of various apps, including xcalc which need to be packaged
for Extras and planned on whipping up initial rpms and posting email to
fedora-devel-list to see if anyone is interested in maintaining them.  I
just haven't gotten around to that yet.  ;o)

I'll post an update here and to the list once I find the time to go through
the various apps and whip up some packages.

Thanks for the reminder.

Comment 3 Søren Sandmann Pedersen 2006-09-07 22:03:39 EDT
As Mike hints, some of the older X applications are not considered suitable for
Fedora Core; with the modularization of X, these applications can easily be
packaged as part of Fedora Extras.

I am going to close this bug WONTFIX, since I don't think it is useful to keep a
bug open that basically says "xcalc should be shipped in extras".

Note You need to log in before you can comment on or make changes to this bug.