Bug 198585 - hard-coded references to buildsys-build
hard-coded references to buildsys-build
Status: CLOSED NEXTRELEASE
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clark Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 23:34 EDT by Ralf Corsepius
Modified: 2013-01-09 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 10:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-07-11 23:34:21 EDT
Description of problem:

/usr/bin/mock contains this:
..
    config_opts['chroot_setup_cmd'] = 'install buildsys-build'
..
i.e. a hard-coded reference to buildsys-build*.rpm

The same can be found in /etc/mock/defaults.cfg:
..
config_opts['chroot_setup_cmd'] = 'install buildsys-build'
..


As of today, http://fedoraproject.org/buildgroups however only provides
buildsys-build rpms for FC >= 3, while FE-mock ships configurations
(/etc/mock/*.cfg) to support distros < FC3.

=> This can't work.

AFAIS, as a minimal requirement to get mock working for older distros, either
* buildsys-build rpms will have to be added to fedoraproject.org/buildgroups,
 or
* config_opts['chroot_setup_cmd'] in /etc/mock/*.cfg will have to be setup
differently.

Version-Release number of selected component (if applicable):
mock-0.6-4.fc5
Comment 1 Clark Williams 2006-08-16 12:32:37 EDT
buildsys-build RPMs have been generated for all supported distros. Has this
resolved your issue?

Comment 2 Ralf Corsepius 2006-08-16 21:50:56 EDT
(In reply to comment #1)
> buildsys-build RPMs have been generated for all supported distros. Has this
> resolved your issue?
Well, you've fixed the symptoms ("supported distros"), but you've not fixed the
cause (An incorrect default in "default.cfg").
Comment 3 Clark Williams 2006-08-17 10:07:19 EDT
I don't see what you mean. We've generated buildsys-build rpms for all supported
distros (rhl[79] for legacy, FC[1-5] and development), so that any target config
that does an install wil find a buildsys-build, download it and install it for
dependencies. 

Are you saying that the symlink that is default.cfg is pointing to an incorrect
file, or that the contents of the .cfg file referenced by default.cfg is
incorrect? If the latter, then what precisely do you find incorrect?
Comment 4 Ralf Corsepius 2006-08-17 23:53:14 EDT
(In reply to comment #3)
> I don't see what you mean.
Sorry, my last comment wasn't entirely correct.

I was referring to the default config_opts in /usr/bin/mock, not default.cfg:

    config_opts['chroot_setup_cmd'] = 'install buildsys-build'

This causes mock to fail for all distros you don't have under your control.

I.e. the bug is mock using this line above as default.
Comment 5 Clark Williams 2006-08-18 10:03:47 EDT
As I was writing another, "but I don't understand!" reply, I realized what the
problem is. You don't have a way to build a buildsys-build package for say Bob's
Linux (or Ralf's Linux, in this case). 

That is being corrected in the next release, since the buildsys-build.spec file
will be included in /usr/share/doc/mock. With this you should be able to tailor
the contents of a buildsys-build package for your distro.

Note You need to log in before you can comment on or make changes to this bug.