Bug 1986235 - Grub menu loads line by line instead of instantly
Summary: Grub menu loads line by line instead of instantly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-27 02:18 UTC by Andrey Kozlovskiy
Modified: 2022-03-20 20:01 UTC (History)
9 users (show)

Fixed In Version: grub2-2.06-16.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-24 19:00:59 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Video of entering GRUB menu (3.49 MB, video/webm)
2021-07-27 02:18 UTC, Andrey Kozlovskiy
no flags Details

Description Andrey Kozlovskiy 2021-07-27 02:18:40 UTC
Created attachment 1806159 [details]
Video of entering GRUB menu

Created attachment 1806159 [details]
Video of entering GRUB menu

Description of problem:

I am using Fedora Silverblue 34.20210725.0 on Lenovo IdeaPad S340-14IIL.

I have a strange problem when entering GRUB menu: it loads line by line, and it takes a few seconds. All keys that were pressed while the menu was loading are handled after the loading is complete.

I recorded a short video, I hope it explains the problem more clearly.

Version-Release number of selected component (if applicable):

grub2-efi-x64-2.06-2.fc34.x86_64

How reproducible:

Always.

Steps to Reproduce:

For example, press ESC in UEFI mode during boot to display the menu.

Actual results:

Slow, line by line menu loading with running cursor.

Expected results:

Menu loads instantly without cursor running line by line in a sequential manner.

Additional info:

Output of `sudo grub2-editenv list`:
```
menu_auto_hide=1
boot_success=1
boot_indeterminate=0
```

Comment 1 Hans de Goede 2022-01-28 13:13:21 UTC
Thank you for your bugreport. This sounds a lot like an issue which I hit myself. I've written a set of patches fixing my variant of this issue and submitted it upstream and downstream:

https://lists.gnu.org/archive/html/grub-devel/2022-01/msg00169.html
https://github.com/rhboot/grub2/pull/95

It would be great if you can test the fix and confirm that it fixes things for you too.

Here is a build of the latest fedora-36 branch of grub with the fixes included:
https://fedorapeople.org/~jwrdegoede/rhbz1946969/grubx64.efi

To test this backup /boot/efi/EFI/fedora/grubx64.efi (in case the new one does not work) and then copy the linked file to /boot/efi/EFI/fedora/grubx64.efi with it. Note this is not signed and as such you will need to disable secure-boot to test this. Warning disabling secureboot and running semi-random binaries from the internet is not the best idea from a security pov.

Note the menu looks slightly different in the fedora-36 branch, because a couple of downstream patches which tweak the menu look have been dropped to bring us closer to the upstream grub sources.

Comment 2 Jordan Pisaniello 2022-02-08 18:36:35 UTC
Hi all,

I was able to fix this issue by just simply running:

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

on my ThinkPad T14. If there's a way to 'revert' my fix, I would be happy to test the latest fedora-36 branch.

I'm running Fedora 35 with:

grub2-common-2.06-10.fc35.noarch
grub2-tools-minimal-2.06-10.fc35.x86_64
grub2-tools-2.06-10.fc35.x86_64
grub2-pc-modules-2.06-10.fc35.noarch
grub2-pc-2.06-10.fc35.x86_64
grub2-efi-ia32-2.06-10.fc35.x86_64
grub2-efi-x64-2.06-10.fc35.x86_64
grub2-tools-extra-2.06-10.fc35.x86_64
grub2-efi-ia32-cdboot-2.06-10.fc35.x86_64
grub2-efi-x64-cdboot-2.06-10.fc35.x86_64
grub2-tools-efi-2.06-10.fc35.x86_64

I also want to include some relevant discussions around the web for further reading/completeness:

* https://www.reddit.com/r/linuxquestions/comments/nvh3bj/issue_when_grub_launches_in_fedora_34/
* https://community.frame.work/t/fedora-linux-35-on-the-framework-laptop/6613


Note You need to log in before you can comment on or make changes to this bug.