Bug 1986310 - F35FailsToInstall: python3-libnmstate
Summary: F35FailsToInstall: python3-libnmstate
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: nmstate
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fernando F. Mancera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1989014 (view as bug list)
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-07-27 09:01 UTC by Miro Hrončok
Modified: 2021-10-08 17:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-08 17:08:01 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-07-27 09:01:22 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (nmstate) Fails To Install in Fedora 35:

can't install python3-libnmstate:
  - nothing provides python3.10dist(nispor) >= 1.1 needed by python3-libnmstate-1.1.0-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-08-02 10:09:41 UTC
*** Bug 1989014 has been marked as a duplicate of this bug. ***

Comment 2 Miro Hrončok 2021-08-03 10:45:17 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Fernando F. Mancera 2021-08-03 10:54:50 UTC
(In reply to Miro Hrončok from comment #2)
> Hello,
> 
> This is the first reminder (step 3 from
> https://docs.fedoraproject.org/en-US/fesco/
> Fails_to_build_from_source_Fails_to_install/
> #_package_removal_for_long_standing_ftbfs_and_fti_bugs).
> 
> If you know about this problem and are planning on fixing it, please
> acknowledge so by setting the bug status to ASSIGNED. If you don't have time
> to maintain this package, consider orphaning it, so maintainers of dependent
> packages realize the problem.

Hello, I am working on it. Moving it to assigned. Thanks!

Comment 4 Ben Cotton 2021-08-10 13:15:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 5 Miro Hrončok 2021-09-11 05:43:09 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 6 Fernando F. Mancera 2021-09-26 00:56:13 UTC
This will be fixed by: https://bodhi.fedoraproject.org/updates/FEDORA-2021-e3db66a045

Comment 7 Miro Hrončok 2021-10-08 17:08:01 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.