Bug 198656 - lighttpd version 1.4.10
lighttpd version 1.4.10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lighttpd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 11:30 EDT by Tautvydas Bruzas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-12 13:29:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tautvydas Bruzas 2006-07-12 11:30:11 EDT
Description of problem:
Lighttpd version 1.4.10-2 have few not very high priority, but anoying bugs. One
of them, if you try to redirect http traffic to https for specific location you
can't write config file to match on port 80 it tries to bind on that.

Version-Release number of selected component (if applicable):
Versions prior to 1.4.11

How reproducible:
Easily.

Steps to Reproduce:
1. Try to match on on port 80 in you config file by including this directive:

$SERVER["socket"] == ":80" {
  $HTTP["host"] =~ "example.org" {
    url.redirect = ( "^/(.*)" => "https://example.org/$1" )
    server.name                 = "example.org"
  }
}
2. Restart lighttpd.
3.It fails with message "Starting lighttpd: 2006-07-12 10:25:45: (network.c.300)
can't bind to port:  80 Address already in use".
  
Actual results:
Cann't do matching on port, which makes harder redirecting https traffic.

Additional info:
This has been fixed in version 1.4.11.
Comment 1 Matthias Saou 2006-07-12 13:29:55 EDT
Argh. I've been using 1.4.11 on RHEL since it's been released, and could have
sworn I had updated the Extras packages too... but nope. Expect them to be
pushed very shortly, and thanks a lot for the notice.

Note You need to log in before you can comment on or make changes to this bug.