Bug 19866 - apache-1.3.14-3.src.rpm does not rebuild
apache-1.3.14-3.src.rpm does not rebuild
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-26 11:14 EDT by wayne
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 16:50:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wayne 2000-10-26 11:14:38 EDT
Attempting to build this RPM results in the following error :

+ '%{makeinstall}' sysconfdir=/var/tmp/apache-root/usr/etc/httpd/conf
includedir=/var/tmp/apache-root/usr/include/apache
libexecdir=/var/tmp/apache-root/usr/lib/apache
iconsdir=/var/tmp/apache-root/var/www/icons
htdocsdir=/var/tmp/apache-root/var/www/html
cgidir=/var/tmp/apache-root/var/www/cgi-bin
runtimedir=/var/tmp/apache-root/var/httpd
logfiledir=/var/tmp/apache-root/var/log/httpd
proxycachedir=/var/tmp/apache-root/var/cache/httpd
/var/tmp/rpm-tmp.70867: fg: no job control
Bad exit status from /var/tmp/rpm-tmp.70867 (%install)

Doing sh /var/tmp/rpm-tmp.70867 produces the error 

ln: cannot create symbolic link `/var/tmp/apache-root/etc/httpd/conf' to
`../../../usr/share/ssl/certs/Makefile': No such file or directory
+ find /var/tmp/apache-root -type f
+ xargs perl -pi -e 's|/usr/local/bin/perl5|/usr/bin/perl|g;'
+ xargs grep -l /usr/local/bin/perl5
+ find /var/tmp/apache-root -type f
+ xargs grep -l /usr/local/bin/perl
+ xargs perl -pi -e 's|/usr/local/bin/perl|/usr/bin/perl|g;'
+ sed 's^/var/tmp/apache-root^^g' /var/tmp/apache-root/usr/sbin/apxs
sed: can't read /var/tmp/apache-root/usr/sbin/apxs: No such file or
directory
+ /usr/share/spec-helper/spec-helper
Cleaning files...done
Compressing files...done
Stripping files...done
Relativisation of symlinks...done

It looks like the apxs is not being installed right. I've looked at the
spec file and can't see the problem.

System is a PIII-500, Mandrake 7.1. Have also tried on a P166 with RedHat 7
with the same error.
Comment 1 Nalin Dahyabhai 2000-10-30 15:59:44 EST
Which release is this?  Which version of RPM are you using (recent versions
should define the %makeinstall macro)?  It appears that %makeinstall is not
defined, so RPM is passing it unchanged to the shell, which treats it as a job
control command.
Comment 2 wayne 2000-10-30 16:50:35 EST
Using apache-1.3.14-3.src.rpm (release 3 I think?)
Comment 3 Arenas Belon, Carlo Marcelo 2000-11-03 01:41:05 EST
%{makeinstall} is defined on RPM 3.0.5, sounds like an rpm problem to me

just to be sure i've just rebuilt thet apache-1.3.14-3 RPM after on a RH 7.0
system + patches (after installing db1-devel)

make sure that there are is no error message on build or while configure is
called.

Note You need to log in before you can comment on or make changes to this bug.