Bug 1986708 - Single stack external gateway makes the pod not starting with dual stack clusters
Summary: Single stack external gateway makes the pod not starting with dual stack clus...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Federico Paolinelli
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 1977330
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-28 07:29 UTC by Federico Paolinelli
Modified: 2021-10-12 06:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1977330
Environment:
Last Closed: 2021-10-12 06:01:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 774 0 None open Bug 1986708: Add routes for pod: fail only after checking all the gw addresses / ips 2021-09-29 21:14:00 UTC
Red Hat Product Errata RHBA-2021:3682 0 None None None 2021-10-12 06:01:56 UTC

Description Federico Paolinelli 2021-07-28 07:29:41 UTC
+++ This bug was initially created as a clone of Bug #1977330 +++

Description of problem:

Pod gets stuck in ContainerCreating when a gwip is single stack (i.e. ipv4 only) in a dual stack cluster

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
On a dual stack cluster:

1. Create a gw pod with annotations like:

      k8s.ovn.org/routing-namespaces: test
      k8s.ovn.org/routing-network: foo
      k8s.v1.cni.cncf.io/network-status: '[{"name":"foo","interface":"net1","ips":["172.19.0.5"],"mac":"01:23:45:67:89:10"}]'

2. Create a pod in the test namespace


Actual results:
Pod gets stuck in "container creating"

Expected results:
Pod goes running

Additional info:

Comment 6 errata-xmlrpc 2021-10-12 06:01:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.14 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3682


Note You need to log in before you can comment on or make changes to this bug.