Bug 198671 - slab corruption / slab error in slab_destroy_objs(): cache `bio'
slab corruption / slab error in slab_destroy_objs(): cache `bio'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
Depends On:
Blocks: fedora-ia64 209053
  Show dependency treegraph
 
Reported: 2006-07-12 13:18 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 14:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel messages from slab corruption runing the "busy2" test on hpdiablo1 (22.97 KB, text/plain)
2006-07-12 13:18 EDT, Doug Chapman
no flags Details

  None (edit)
Description Doug Chapman 2006-07-12 13:18:01 EDT
Description of problem:
Seen on one of my HP ia64 Integrity servers running a proprietary HP test suite.
   Since all the messages are rather lengthy I wil upload it as an attachment.

But here are some of what think are the more interesting messages:

Slab corruption: (Not tainted) start=e0000040765c2828, len=104
kernel BUG at mm/slab.c:608!
kjournald[541]: bugcheck! 0 [1]

....
slab error in slab_destroy_objs(): cache `bio': start of a freed object was
overwritten


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2364.fc6


How reproducible:
This took about 10 hours of stress testing before it was seen.  I will update
this BZ if I see it again.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2006-07-12 13:18:01 EDT
Created attachment 132317 [details]
kernel messages from slab corruption runing the "busy2" test on hpdiablo1
Comment 2 Prarit Bhargava 2006-10-16 13:56:25 EDT
We haven't seen this again, have we?  Doug, any objections to closing this out?

P.
Comment 3 Doug Chapman 2006-10-16 14:29:35 EDT
I have not seen this in a while, yes I am OK with closing it.

Note You need to log in before you can comment on or make changes to this bug.