Bug 198697 - mrtg install uses incorrect directory for log files
mrtg install uses incorrect directory for log files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
5
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 17:27 EDT by Don Russell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-15 21:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2006-07-12 17:27:40 EDT
Description of problem:
After installing mrtg (yum install mrtg) the sample log file causes logs to be
placed in /var/lib instead of /var/log. Of course the sample could be changed by
the user, but the mrtg directory is also created in /var/lib instead of /var/log

Upstream doc suggests using /var/log... 
Ref: http://oss.oetiker.ch/mrtg/doc/mrtg-unix-guide.en.html in the "Running
mrtg" section.

Version-Release number of selected component (if applicable):
2.13.2.0.fc5.1

How reproducible:
Always (I suspect some form of a typo in the rpm packaging/installing script)


Steps to Reproduce:
1. yum install mrtg
2. vim /etc/mrtg/mrtg.cfg
3.
  
Actual results:
LogDir: /var/lib/mrtg
An mrtg directory is created in /var/lib


Expected results:
LogDir: /var/log/mrtg
An mrtg directory should be created in /var/log


Additional info:
Comment 1 Don Russell 2006-07-12 17:30:05 EDT
Perhaps this could be be addressed when the package is rebuilt for a newer
version of mrtg. (There have been several releases since this 2.13.2.0 one,
2.14.4 is the latest, released 4 July 2006)

Comment 2 Miloslav Trmač 2006-07-15 21:52:41 EDT
The "running mrtg" section talks about --logging, a place for warning and error
messages.

LogDir on the other hand is the place for the mrtg _data_ files (not event logs
for system administration that can be removed or truncated without affecting
system operation, like the other files in /var/log).  Such data files do belong
in /var/lib.


Fedora Core releases are not in general updated to new package versions just
as they are available; the development branch already contains mrtg-2.14.4.

Note You need to log in before you can comment on or make changes to this bug.