Bug 198702 - Cannot upgrade FC2 with LVM to FC5
Cannot upgrade FC2 with LVM to FC5
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-07-12 18:11 EDT by Andrew D. Stadler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-15 14:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew D. Stadler 2006-07-12 18:11:00 EDT
Description of problem:

I have a server which was set up using FC2.  Besides the usual boot drive, this
server has a hardware (3ware) RAID-1 on which I have used LVM to create two
partitions (/home and /usr/local/perforce).  This system was created and set up
with the FC2 installer and has worked perfectly since then.

Now, the FC5 installer DVD refuses to update this system, with complaints.

Version-Release number of selected component (if applicable):
Anaconda running on FC5 DVD .iso

How reproducible:

Steps to Reproduce:
1.  Create system using anaconda on FC2.  Original volume layout is as follows.
On /dev/sdb (boot volume):
    * /dev/sdb1 small Dell FAT16 volume, not used
    * /dev/sdb2 (label "/boot") mounts as /boot
    * /dev/sdb3 (label "/") mounts as /
    * /dev/sdb4 extended partition map
    * /dev/sdb5 mounts as swap 
On /dev/sda aka hardware RAID-1 aka LVM VG "vg_raid":
    * /dev/vg_raid/lv_homes 40 GB mounted as /home
    * /dev/vg_raid/lv_perforce 40 GB mounted as /usr/local/perforce 

2.  Run with FC2 for over a year, no significant changes or problems.
3.  Reboot into FC5 installer DVD
Actual results:
Two errors pop up.
(1)  During phase "searching for fedora core installations" it gives the error
"Error mounting file system on sda1: Invalid argument" (see anaconda log data below)

(2)  If I plow through and select upgrade onto "Fedora Core 2 (sdb3)" I see the
following error dialog:
  "Error mounting device vg_raid/lv_homes as /home: No such file or directory"
(see anaconda log data below)

Expected results:
Normal upgrade with success

Additional info:

1.  Removed DVD and rebooted into existing FC2.  No problems reported in any
volumes or partitions.

2.  From alt-f3 after the first error message, this may be related:
INFO: moving (1) to step findrootparts
WARNING: /usr/lib/python2.4/site-packages/snack.py:250: DeprecationWarning:
integer argument expected, got float

3.  This may or may not be related but I am also seeing, in alt-f4,
<4>program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO
[..repeated a few times..]
<4>JBD: no valid journal superblock found
<3>EXT3-fs: error loading journal

4.  Here's anaconda logging around the time of the 2nd error (about the LVM
mount failure)
INFO: moving (1) to step upgrademount
INFO: going to mount sdb3 on /mnt/sysimage as ext3
INFO: trying to mount sdb3 on /
INFO: trying to mount sdb2 on /boot
INFO: trying to mount vg_raid/lv_homes on /home

(note, the mount points that were listed are essentially correct)
Comment 1 Andrew D. Stadler 2006-07-12 18:31:52 EDT
I have also tried this with an FC4 installer DVD and although the look and feel
were different, the two error message dialogs were exactly the same.

(I was in graphical installer so I did not have an opportunity to view the logs)
Comment 2 Andrew D. Stadler 2006-07-12 19:40:38 EDT
Since the data on my RAID is strictly user data - there are no system files - I
decided to try upgrading without the RAID.

Failed workaround:
1.  Shut down system
2.  Physically unplug RAID card
3.  Reboot
4.  Repeat installation attempt
5.  No longer says "Error mounting file system on sda1: Invalid argument"
6.  Still says "Error mounting device vg_raid/lv_homes as /home: No such file or

This workaround failed but provided a key clue:  Anaconda is getting upset when
it cannot (for whatever reason) satisfy a mount point in /etc/fstab.  So I
reinstalled the RAID card and tried a different workaround:

1.  Boot into linux rescue
2.  Ignore error messages
3.  cd /sys/mntimage/etc
4.  cp fstab fstab_backup_fc5
5.  vi fstab
6.  place '#' before the lines that mount from /dev/vg_raid/...
7.  save and quit
8.  reboot into FC5 anaconda

Good news:  This seems to get through the difficulties and get into the
installation process.
Comment 3 Jeremy Katz 2006-07-19 11:57:10 EDT
Does it then mount correctly after the upgrade?
Comment 4 Andrew D. Stadler 2006-07-19 16:37:32 EDT
Sorry, I didn't update the bug after that.

The results of the FC5 upgrade (in comment #2) were a non-booting FC5 system.  I
do not know why, but it was dying early in the kernel init phase.

At this point I was out of time and needed to get the server back on line, so I
wiped the boot partitions, made a new smaller partition, and reinstalled FC2 on
it.  Added my LVM mount points to /etc/fstab and the LVM volumes came right back
on line with no errors reported.

My next step will be to install a fresh (not upgrade) FC5 on a new partition on
the boot drive (I left plenty of room for this sort of thing) and I expect I
will then manually attach the LVM volumes, again.  I will update the bug report
when I do this.
Comment 5 David Cantrell 2007-03-15 14:32:05 EDT
Upgrades from more than one release back are not supported in Fedora.  You can
upgrade FC2 to FC3, FC3 to FC4, and so on.  But not FC2 to FC5.

Note You need to log in before you can comment on or make changes to this bug.