Bug 1987029 - ROKS/hypershift: service-ca-operator produces an operand that selects master nodes
Summary: ROKS/hypershift: service-ca-operator produces an operand that selects master ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ibm-roks-toolkit
Version: 4.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.0
Assignee: Cesar Wong
QA Contact: Jie Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-28 18:31 UTC by Cesar Wong
Modified: 2021-10-26 17:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-26 17:22:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift service-ca-operator pull 171 0 None open Bug 1987029: Support external control plane topology 2021-07-28 18:32:35 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:22:48 UTC

Description Cesar Wong 2021-07-28 18:31:38 UTC
Description of problem:
When running in a topology that has an external control plane like ROKS or Hypershift, workloads should not include a master node selector because there are no master nodes. The service-ca-operator itself is not scheduled on masters because of its cluster profile. However, its operand includes a master node selector.

Version-Release number of selected component (if applicable):
4.9

How reproducible:
Always

Steps to Reproduce:
1. Install 4.9 using Hypershift
2.
3.

Actual results:
The service-ca deployment in openshift-service-ca has a master node selector.

Expected results:
The service-ca deployment in openshift-service-ca does not select masters when Infrastructure.Status.ControlPlaneTopology is 'External'

Additional info:

Comment 7 errata-xmlrpc 2021-10-26 17:22:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.