This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 198712 - Latest Gimp Update will not save .jpg
Latest Gimp Update will not save .jpg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 21:43 EDT by Paul
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-14 05:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul 2006-07-12 21:43:44 EDT
Description of problem:
Opened a .jpg graphic - edited - saved - message "Plug-In crashed: "jpeg"
(/usr/lib/gimp/2.0/plug-ins/jpeg) - tried to create jpg graphic from scratch -
same message on save

Version-Release number of selected component (if applicable):
2.2.17 - downloaded Wednesday, 12 July 2006
downloaded twice (downloaded/erase/download)

How reproducible:
Always

Steps to Reproduce:
1. create .jpg graphic
2. save
3. error message
  
Actual results:
error message

Expected results:
graphic saved to disk

Additional info:
Comment 1 Nils Philippsen 2006-07-13 07:56:39 EDT
I assume you have version 2.2.12, not 2.2.17 (that doesn't exist (yet)).

I couldn't reproduce this on my machine (neither with existing nor new image).

Do you have all other updates applied?
Do you have SELinux enabled (check with "getenforce")?
Comment 2 Paul 2006-07-13 15:00:37 EDT
Good Day

Thank You for the quick reply.

The version number is 2.2.12.

Yes. I downloaded a batch of about 18 updates yesterday. This worked the night
before last but not now.

No. I use Reiserfs.

I can create and save .jpg files as a user but not as root. The Gimp was working
in the root directory for a little added security. I followed the path on the
error message and I changed the ownership of the plugin directory to that of the
user that worked. I can now save .jpg files as root(?).

This is a poor solution but it works.

A brief look around suggests that the MIT-MAGIC COOKIE is to blame. Instead of
one .xauthority file in root now I have several (.xauth?????). I went through
backups and prior to yesterday I only had one .xauthority file in root. That
must be part of the problem. I tried to restore one of the older .xauthority
files to the root directory but it did not work.

It will give me something to do for the weekend.

Mark this bug, "Probably Not Gimp's fault!"
Comment 3 Nils Philippsen 2006-07-14 05:16:11 EDT
My advice is: don't do this.

Running any other normal application not needed for system administration as
root doesn't result in increased security, quite the contrary. This is even more
valid for apps like GIMP that deal with complex format, potentially untrusted files.

Note You need to log in before you can comment on or make changes to this bug.