Bug 1987156 - [abrt] cinnamon: module(): cinnamon-subprocess-wrapper:30:<module>:AttributeError: 'str' object has no attribute 'decode'
Summary: [abrt] cinnamon: module(): cinnamon-subprocess-wrapper:30:<module>:AttributeE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:101df9dab9a4e64398480d43256...
: 1992602 1993086 2001610 2003635 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-29 05:50 UTC by frywalker
Modified: 2021-10-09 00:21 UTC (History)
10 users (show)

Fixed In Version: cinnamon-5.0.5-4.fc35 cinnamon-5.0.5-4.fc34
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-05 00:51:03 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.23 KB, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details
File: cpuinfo (2.52 KB, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details
File: environ (3.17 KB, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details
File: mountinfo (2.96 KB, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details
File: namespaces (172 bytes, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details
File: open_fds (641 bytes, text/plain)
2021-07-29 05:50 UTC, frywalker
no flags Details

Description frywalker 2021-07-29 05:50:08 UTC
Version-Release number of selected component:
cinnamon-5.0.4-1.fc34

Additional info:
reporter:       libreport-2.15.2
cgroup:         0::/user.slice/user-1000.slice/session-2.scope
cmdline:        cinnamon-subprocess-wrapper '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
crash_function: module
exception_type: AttributeError
executable:     /usr/bin/cinnamon-subprocess-wrapper
interpreter:    cinnamon-5.0.4-1.fc34.x86_64
kernel:         5.13.4-200.fc34.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
cinnamon-subprocess-wrapper:30:<module>:AttributeError: 'str' object has no attribute 'decode'

Traceback (most recent call last):
  File "/usr/bin/cinnamon-subprocess-wrapper", line 30, in <module>
    GLib.Variant("(isb)", (process_id, result.decode(), success)),
AttributeError: 'str' object has no attribute 'decode'

Local variables in innermost frame:
__name__: '__main__'
__doc__: ' Runs a command and then passes the output to Cinnamon via DBus asynchronously\n\nUsage:  cinnamon-subprocess-wrapper ls ~/\n'
__package__: None
__loader__: <_frozen_importlib_external.SourceFileLoader object at 0x7f34a3784c10>
__spec__: None
__annotations__: {}
__builtins__: <module 'builtins' (built-in)>
__file__: '/usr/bin/cinnamon-subprocess-wrapper'
__cached__: None
subprocess: <module 'subprocess' from '/usr/lib64/python3.9/subprocess.py'>
sys: <module 'sys' (built-in)>
setproctitle: <built-in function setproctitle>
GLib: <GLibProxyModule <IntrospectionModule 'GLib' from '/usr/lib64/girepository-1.0/GLib-2.0.typelib'>>
Gio: <GioProxyModule <IntrospectionModule 'Gio' from '/usr/lib64/girepository-1.0/Gio-2.0.typelib'>>
process_id: 1
result: ''
success: False
connection: <Gio.DBusConnection object at 0x7f34a2082440 (GDBusConnection at 0x5604e9053070)>

Comment 1 frywalker 2021-07-29 05:50:11 UTC
Created attachment 1806970 [details]
File: backtrace

Comment 2 frywalker 2021-07-29 05:50:13 UTC
Created attachment 1806971 [details]
File: cpuinfo

Comment 3 frywalker 2021-07-29 05:50:14 UTC
Created attachment 1806972 [details]
File: environ

Comment 4 frywalker 2021-07-29 05:50:16 UTC
Created attachment 1806973 [details]
File: mountinfo

Comment 5 frywalker 2021-07-29 05:50:17 UTC
Created attachment 1806974 [details]
File: namespaces

Comment 6 frywalker 2021-07-29 05:50:18 UTC
Created attachment 1806975 [details]
File: open_fds

Comment 7 Andrey 2021-08-11 11:59:56 UTC
*** Bug 1992602 has been marked as a duplicate of this bug. ***

Comment 8 rjkon007 2021-08-12 11:26:26 UTC
*** Bug 1993086 has been marked as a duplicate of this bug. ***

Comment 9 jay 2021-09-06 14:40:38 UTC
*** Bug 2001610 has been marked as a duplicate of this bug. ***

Comment 10 demcharly 2021-09-13 11:00:02 UTC
*** Bug 2003635 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2021-09-30 13:57:52 UTC
FEDORA-2021-986152d6bd has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-986152d6bd

Comment 12 Fedora Update System 2021-10-01 01:39:08 UTC
FEDORA-2021-d5c01b29e7 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d5c01b29e7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d5c01b29e7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2021-10-01 02:19:52 UTC
FEDORA-2021-986152d6bd has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-986152d6bd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-986152d6bd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-10-05 00:51:03 UTC
FEDORA-2021-d5c01b29e7 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2021-10-09 00:21:37 UTC
FEDORA-2021-986152d6bd has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.