Bug 198730 - Does not show Bold and Italic style for embolden and artificial oblique
Does not show Bold and Italic style for embolden and artificial oblique
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 01:54 EDT by Leon Ho
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-30 14:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (3.80 KB, patch)
2006-09-27 10:32 EDT, Akira TAGOH
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 319808 None None None Never

  None (edit)
Description Leon Ho 2006-07-13 01:54:56 EDT
Description of problem:
We enable artificial oblique and embolden for fonts which do not have bold and
italic style fonts, but user couldn't choose those two styles when they select
an individual font.

How reproducible:
everytime

Steps to Reproduce:
1. gedit
2. Edit -> Preference
3. Fonts & Color -> Editor font
4. Choose "Baekmuk Gulim"

Actual results:
In Style column, it shows "Regular" only.

Expected results:
In Style column, it should show "Regular; Italic; and Bold"
Comment 1 Akira TAGOH 2006-09-27 10:32:08 EDT
Created attachment 137224 [details]
proposed patch

Behdad, I wrote a patch for Pango to enable the synthetic embolden/oblique
features in fontconfig/freetype. this could be done in fontconfig though, it
may be intentional why fontconfig didn't do so since it has separate flag like
FC_EMBOLDEN and some applications may not wants to use it.
If you think that it should be implemented in fontconfig anyway, please let me
know.
Comment 2 Akira TAGOH 2006-09-27 10:33:16 EDT
reassigning to pango so far.
Comment 3 Behdad Esfahbod 2006-09-27 18:25:50 EDT
There's an upstream bug about this, with a patch that I committed once but had
to revert:

  http://bugzilla.gnome.org/show_bug.cgi?id=319808

I'll probably look into it not before next weekend during the GNOME Boston summit.
Comment 4 Liang Zhang 2007-09-27 23:27:47 EDT
This bug in the upstream bugzilla is:
http://bugzilla.gnome.org/show_bug.cgi?id=319808

And this bug in the upstream bugzilla has already been fixed.
So this bug can be closed.


Note You need to log in before you can comment on or make changes to this bug.