Bug 1987315 - OpenShift web console not deployed after installing OCP 4.8.2 using single-node-developer profile [NEEDINFO]
Summary: OpenShift web console not deployed after installing OCP 4.8.2 using single-no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1986129
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-29 13:32 UTC by OpenShift BugZilla Robot
Modified: 2021-09-21 08:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-21 08:02:17 UTC
Target Upstream Version:
yanpzhan: needinfo? (jhadvig)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 981 0 None None None 2021-09-03 19:24:48 UTC
Github openshift console-operator pull 591 0 None open [release-4.8] Bug 1987315: Bump openshift/api to add missing 'include.release.openshift.io/single-node-developer' annota... 2021-09-14 12:37:38 UTC
Red Hat Product Errata RHBA-2021:3511 0 None None None 2021-09-21 08:02:18 UTC

Description OpenShift BugZilla Robot 2021-07-29 13:32:21 UTC
+++ This bug was initially created as a clone of Bug #1986129 +++

Description of problem:

Installed OCP 4.8.2 using the single-node-developer profile:

$ export OPENSHIFT_INSTALL_EXPERIMENTAL_CLUSTER_PROFILE=single-node-developer
$ oc create manifests
$ oc create ignition-configs


Version-Release number of selected component (if applicable):

4.8.2, link https://mirror.openshift.com/pub/openshift-v4/clients/ocp/4.8.2/

How reproducible:

Just install OpenShift 4.8.2 using the single-node-developer profile

Actual results:

The console cluster operator won't become available:

$ oc get clusteroperator
NAME                                       VERSION   AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                             4.8.2     True        False         False      23m
baremetal
cluster-autoscaler                         4.8.2     True        False         False      39m
config-operator                            4.8.2     True        False         False      40m
console                                    4.8.2     False       False         False      32m
csi-snapshot-controller                    4.8.2     True        False         False      40m
dns                                        4.8.2     True        False         False      40m
etcd                                       4.8.2     True        False         False      39m
image-registry                             4.8.2     True        False         False      33m
ingress                                    4.8.2     True        False         False      34m
insights                                   4.8.2     True        False         False      33m
kube-apiserver                             4.8.2     True        False         True       35m
kube-controller-manager                    4.8.2     True        False         False      39m
kube-scheduler                             4.8.2     True        False         False      36m
machine-api                                4.8.2     True        False         False      39m
machine-approver                           4.8.2     True        False         False      40m
machine-config                             4.8.2     True        False         False      39m
marketplace                                4.8.2     True        False         False      39m
monitoring                                 4.8.2     True        False         False      31m
network                                    4.8.2     True        False         False      41m
node-tuning                                4.8.2     True        False         False      39m
openshift-apiserver                        4.8.2     True        False         False      33m
openshift-controller-manager               4.8.2     True        False         False      39m
openshift-samples                          4.8.2     True        False         False      32m
operator-lifecycle-manager                 4.8.2     True        False         False      40m
operator-lifecycle-manager-catalog         4.8.2     True        False         False      40m
operator-lifecycle-manager-packageserver   4.8.2     True        False         False      33m
service-ca                                 4.8.2     True        False         False      40m
storage                                    4.8.2     True        False         False      40m

Console pod is not deployed at all.

Expected results:

The console cluster operator should deploy console.

Additional info:

This issue is caused by the cluster-version-operator not deploying consoleplugin CRD. After applying this CRD manually to the cluster, the console is deployed and the console operator becomes available. This is the command that fixes the issue for me:

$ oc rsh -n openshift-cluster-version cluster-version-operator-789d46ff9d-lbcn4 cat /release-manifests/0000_10_consoleplugin.crd.yaml | oc apply -f -
customresourcedefinition.apiextensions.k8s.io/consoleplugins.console.openshift.io created

Comment 1 Yanping Zhang 2021-09-06 08:21:51 UTC
@Jakub, if the fix in pr https://github.com/openshift/api/pull/981/files needs to be bumped into console-operator repo, so that we can check the fix on 4.8 console?

Comment 4 Yanping Zhang 2021-09-14 05:51:09 UTC
There is no bump pr in console operator repo for the bug, assign the bug back.

Comment 7 errata-xmlrpc 2021-09-21 08:02:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.12 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3511


Note You need to log in before you can comment on or make changes to this bug.