Bug 198734 - pdksh prompt skips to last newline in emacs mode
pdksh prompt skips to last newline in emacs mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pdksh (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks: FAST4.5APPROVED
  Show dependency treegraph
 
Reported: 2006-07-13 02:47 EDT by Michael Glasgow
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0667
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 10:57:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
emacsmode2.patch (353 bytes, patch)
2006-07-13 02:49 EDT, Michael Glasgow
no flags Details | Diff

  None (edit)
Description Michael Glasgow 2006-07-13 02:47:05 EDT
Description of problem:

pdksh no longer displays multi-line shell prompts in emacs mode

Version-Release number of selected component (if applicable):

pdksh-5.2.14-30.3

How reproducible:

Set PS1 to any string containing a newline and enable emacs mode.

Steps to Reproduce:

ksh -o emacs
PS1='abc
123 '
  
Actual results:

Prompt looks like:
123

Expected results:

Should look like:
abc
123


Additional info:

The emacsmode patch in 30.3 broke multi-line shell prompts.  Though I'd never 
use such a thing myself, some of our users have been for years, and they want 
the old behavior back.

It looks easy enough to fix (patch attached).
Comment 1 Michael Glasgow 2006-07-13 02:49:57 EDT
Created attachment 132347 [details]
emacsmode2.patch
Comment 15 errata-xmlrpc 2007-11-15 10:57:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0667.html

Note You need to log in before you can comment on or make changes to this bug.