Bug 198761 - Monotone-Server doesn't start due to permission problems
Monotone-Server doesn't start due to permission problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: monotone (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 08:06 EDT by Thomas Moschny
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.30-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 14:58:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Moschny 2006-07-13 08:06:48 EDT
Description of problem:
The monotone server doesn't start, because it can't create the pid 
file /var/run/monotone-server.pid.

Version-Release number of selected component (if applicable):
monotone-server-0.27-1.fc5

How reproducible:
Always.

Steps to Reproduce:
1. service start monotone
2. service status monotone
3. less /var/log/monotone
  
Actual results:
Monotone server is not running.
The log tells us that the PID-file couldn't be created.

Expected results:
Monotone server running.

Additional info:
None.
Comment 1 Roland McGrath 2006-07-13 15:33:00 EDT
Please attach the log with the exact error messages.
Were you root when you ran service start?  
Do you have SELinux enabled?
Comment 2 Thomas Moschny 2006-07-13 15:47:33 EDT
No, I don't have SELinux enabled.

The problem is that the mtn binary itself is told to create the pid file via 
the --pid-file option, but is run as user 'monotone'; and /var/run has 755 
permissions.

So one solution could be to have a subdir of /var/run in the package that 
is writeable by user 'monotone'.
Comment 3 Thomas Moschny 2006-07-14 03:02:49 EDT
And yes, I was root when I ran service start.

The log error message is in German (so on a side note, /etc/init.d/monotone 
should probably set LC_ALL=C). The relevant part is this:

monotone-server: Fehler: Konnte PID-Datei '/var/run/monotone-server.pid' nicht 
erstellen

which translates to

monotone-server: Error: Could not create 
pid-file '/var/run/monotone-server.pid'

Comment 4 Roland McGrath 2006-08-03 19:12:19 EDT
This should be fixed in 0.28-2.  Please verify that things are working well for
you once that build makes its way through the system so you can get it.
Comment 5 Thomas Moschny 2006-08-08 05:48:48 EDT
Now, the service can't be restarted, because the 
pid-file "/var/run/monotone/monotone-server.pid" is not removed for "service 
stop". Monotone complains about the pid-file being existent upon 
next "service start" and refuses to start.

(It seems to me that killproc tries to remove /var/run/monotone-server.pid 
instead of the correct pid-file.)
Comment 6 Thomas Moschny 2006-11-03 12:09:26 EST
This issue seems to be fixed in monotone-server-0.30-1.fc5.

Note You need to log in before you can comment on or make changes to this bug.