Bug 198766 - anaconda crashes on http install
Summary: anaconda crashes on http install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-13 13:10 UTC by Stefan Geuns
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 15:29:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Geuns 2006-07-13 13:10:53 UTC
Description of problem:
I did a http install with core 6 test 1 and anaconda crashes after I filled in 
the static ip and subnetmask. I get a signal 6 and then the shutdown messages 
(like unmounting file systems etc.) are all over the (blue) screen and it 
tells me to reboot. I have to hold down the laptops on/off button for 4 
seconds before it shuts down.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Download vmlinuz and initrd for core 6 test 1, reboot into these
2. Select http install
3. Enter static ip and subnetmask
  
Actual results:
Crash

Expected results:
Fetch base2.img etc. and continue with install.

Additional info:
FTP does work on same (local) server.

Comment 1 David Cantrell 2006-07-13 18:47:44 UTC
Static IP configuration didn't work in FC6 test 1's loader.  It works in rawhide
now.

Comment 2 Lonni J Friedman 2006-08-07 23:40:08 UTC
I'm seeing the same crash with DHCP in test2.

Comment 3 David Cantrell 2006-08-08 13:13:05 UTC
Please provide the stack trace messages and describe what values you typed in
the network configuration screen.

Thanks.

Comment 4 Lonni J Friedman 2006-08-08 14:02:09 UTC
Turns out this is the same as a few of the other bugzilla bugs where there's a
crash when attempting an http or ftp based installation.  This is triggered when
the directory path that is entered is not preceeded with a /

Comment 5 David Cantrell 2006-08-08 15:29:43 UTC
Yeah, we got a fix for that in to CVS on Friday.


Note You need to log in before you can comment on or make changes to this bug.