Bug 198788 - calc cannot save huge files
calc cannot save huge files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
http://www.openoffice.org/issues/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 11:38 EDT by Sam Steingold
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 11:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
huge CSV file that exhibits the bug (4.18 MB, application/octet-stream)
2006-07-13 11:38 EDT, Sam Steingold
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 67203 None None None Never

  None (edit)
Description Sam Steingold 2006-07-13 11:38:53 EDT
Description of problem:

I have a CSV file with ~40,000 lines and 36 columns (~15MB).
I can open it in calc, and I can do some statistics on it, but I cannot save it.
any attempt to save it fails with calc hanging forever taking 100% CPU
and not modifying the disk.
strace and ltrace reveal nothing (no calls).

Version-Release number of selected component (if applicable):
this is Linux 2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006 i686 i686 i386
GNU/Linux
openoffice.org-calc-2.0.2-5.12.2.i386.rpm

How reproducible:
always

Steps to Reproduce:
1. open CSV file.
2. create a new sheet, do some stats there.
3. try to save ("save as", Ctrl-S &c)
4. agree to the ods format and file name.

the second way:
1. create an ods file
2. create a new sheet which is a "link" to the CSV file
3. try to save (Ctrl-S)

neither works.
  
Actual results:
calc hangs forever taking 100% CPU

Expected results:
file saved

Additional info:
openoffice people cannot reproduce this.
http://www.openoffice.org/issues/show_bug.cgi?id=67203
Comment 1 Sam Steingold 2006-07-13 11:38:55 EDT
Created attachment 132380 [details]
huge CSV file that exhibits the bug
Comment 2 Caolan McNamara 2006-07-18 09:02:48 EDT
I'd say upstream is telling fibs, or has some super computer :-) I see this, and
it seems to be that ScRangeList is ultra-slow with this big document. Perhaps we
can re-implement it in terms of one of the stl containers
Comment 3 Caolan McNamara 2006-07-21 07:29:29 EDT
Well, that didn't work. Some discussion around this at
http://sc.openoffice.org/servlets/ReadMsg?list=dev&msgNo=1784
Comment 4 Caolan McNamara 2007-04-13 11:48:15 EDT
This needs a calc specialist to look at it. Currently upstream this is now
assigned to nn, the calc team lead and so is out of the original bogus
"worksforme, fedora f*cked it up" state

Note You need to log in before you can comment on or make changes to this bug.