Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 198794 - VGs on zSeries zfcp storage not activated at boot
VGs on zSeries zfcp storage not activated at boot
Status: CLOSED DUPLICATE of bug 189494
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 12:20 EDT by Bryn M. Reeves
Modified: 2014-03-16 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 13:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch to rc.sysinit (559 bytes, text/x-patch)
2006-07-13 12:28 EDT, Bryn M. Reeves
no flags Details

  None (edit)
Description Bryn M. Reeves 2006-07-13 12:20:29 EDT
Problem Description
-------------------
On zSeries machines, zSeries Fibre Channel Adapter devices are brought online by
the zcfpconf.sh script provided in s390utils:

[ -x /sbin/zfcpconf.sh ] && /sbin/zfcpconf.sh

This is called from rc.sysinit after initial LVM setup completes so any LVM PVs
present on zfcp devices are not discovered by the initial vgscan/vgchange.

A second pass LVM init is carried out, but only if an /etc/mdadm.conf file for
Software RAID exists.


Steps to reproduce
------------------
1. Create an LVM2 volume group on zfcp attached storage
2. Confirm the VG is accessible
3. Reboot the system
4. Run vgs or vgdisplay

Actual Result:
The VG on zfcp storage is not shown.

Expected Result:
The VG on zfcp storage is activated at boot.
Comment 1 Bryn M. Reeves 2006-07-13 12:28:09 EDT
Created attachment 132384 [details]
proposed patch to rc.sysinit

Proposed patch to rc.sysinit attached:

- Move mdadm-specifics out of 2nd pass LVM activation 
- Add check for /etc/multipath.conf before mp initialization
- Add check for /etc/zfcp.conf to 2nd pass LVM activation
Comment 2 Bill Nottingham 2006-07-13 13:29:29 EDT
Why not just move it earlier?
Comment 3 Bill Nottingham 2006-07-13 13:30:31 EDT

*** This bug has been marked as a duplicate of 189494 ***

Note You need to log in before you can comment on or make changes to this bug.