Bug 198826 - gdb can't grok new hash.
Summary: gdb can't grok new hash.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexandre Oliva
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-13 22:18 UTC by Dave Jones
Modified: 2015-01-04 22:27 UTC (History)
3 users (show)

Fixed In Version: gdb-6.5-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 20:03:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Jones 2006-07-13 22:18:46 UTC
whilst trying to debug a rhythmbox crash ..

Loaded symbols for /usr/lib64/gstreamer-0.10/libgstossaudio.so
BFD: /lib64/ld-linux-x86-64.so.2: don't know how to handle OS specific section
`.gnu.hash' [0x6ffffff6]

warning: Unable to grok dynamic linker /lib64/ld-linux-x86-64.so.2 as an object file

warning: Unable to find dynamic linker breakpoint function.
GDB will be unable to debug shared library initializers
and track explicitly loaded dynamic code.

Comment 1 Dave Jones 2006-07-13 22:19:01 UTC
this was with gdb-6.5-2.fc6

Comment 2 Jan Kratochvil 2006-07-18 18:12:48 UTC
DUPLICATE of Bug 198800.


Comment 3 Jan Kratochvil 2006-08-27 14:00:21 UTC
It should be fixed in gdb-6.5-3:
* Thu Jul 13 2006 Alexandre Oliva <aoliva@redhat.com> - 6.5-3
- Backport support for .gnu.hash sections.

Suggested to CLOSE the bug, tested on gdb-6.5-5.fc6, RawHide 2006-08-27 / i386.



Note You need to log in before you can comment on or make changes to this bug.