Bug 198843 - Yumex total percentage upon Upgrade installs is wrong
Yumex total percentage upon Upgrade installs is wrong
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 19:38 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 08:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-07-13 19:38:08 EDT
Description of problem:
When upgrading packages, the total percentage bar at the bottom is wrong.

It seems that when calculating the percentage, it bases the percent on a yum's
total - which includes the cleanup steps. But when upgrading the packages, the
cleanups are left out, so depending on how many packages you're upgrading, the
progress bar will stick to a certain number then jump to 100% as all cleanups
are finished. For example, I recently did a bunch of upgrades to development
versions of Gnome - And my progress bar stopped at 86% when it stopeed upgrading
packages. It moved on to cleanup, did about 10 - 15 cleanups and stuck 86% then
jumped to 100% once everything was done.

Version-Release number of selected component (if applicable):
yumex-1.1.0-2.0.fc6

How reproducible:
Always

Steps to Reproduce:
1. Refresh repos
2. Choose packages to upgrade
3. Look at the progress bar as 'Cleanups' happen
  
Actual results:
The percent will not increase per cleanup completed. This is fine, but because
the percentage is based on a number with the cleanups included, the bar never
finishes at 100%.

Expected results:
The percentage includes the 'cleanup' steps so that it will reach 100%

Additional info:
Comment 1 Tim Lauridsen 2006-07-15 06:27:02 EDT
I will take a look at this and fix it.
Comment 2 Stewart Adam 2006-08-14 11:34:57 EDT
I just finished testing the 1.1.1 development version, the total percentage was
stuck at 85% as it cleaned up...
Comment 3 Tim Lauridsen 2006-08-16 08:47:33 EDT
it is fix now in SVN, it will be availible when yumex 1.1.1 is released.
Comment 4 Stewart Adam 2006-08-16 15:47:18 EDT
Sweet :)
Stewart

Note You need to log in before you can comment on or make changes to this bug.