Bug 198862 - gimp present for 32bit and 64bit -- why?
gimp present for 32bit and 64bit -- why?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-14 05:38 EDT by Nils Philippsen
Modified: 2014-03-16 23:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 09:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the repo containing both arches (18.88 KB, image/png)
2006-07-14 05:41 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2006-07-14 05:38:28 EDT
Description of problem:

gimp packages (gimp, gimp-devel) are present for i386 and x86_64 and I wonder
why (that causes file conflicts between some doc files).

Version-Release number of selected component (if applicable):
gimp-2.2.12-1.fc6
gimp-devel-2.2.12-1.fc6
Comment 1 Nils Philippsen 2006-07-14 05:41:03 EDT
Created attachment 132421 [details]
screenshot of the repo containing both arches
Comment 2 Nils Philippsen 2006-07-14 05:42:20 EDT
version is rather 2.2.12-1.1.fc6 (not that it matters much)
Comment 3 Bill Nottingham 2006-07-14 12:06:31 EDT
It includes a -devel package; we ship all devel for multiarch.
Comment 4 Nils Philippsen 2006-07-17 07:18:58 EDT
The gimp-devel package is only for developing plug-ins and extensions for the
existing gimp binary package. The 32bit gimp package is only present on x86_64
because the 32bit gimp-devel package requires it, the latter is only required if
you need to build stuff for the former. Please exclude 32bit gimp-devel on
x86_64, on the one hand this saves more than 10MB on the media, on the other
this saves me the hassle to unnecessarily split off (build-time generated) gimp
documentation to avoid multiarch file conflicts.
Comment 5 Bill Nottingham 2006-07-17 09:46:34 EDT
I don't know that excluding particular -devel packages is feasible. Jesse?
Comment 6 Jesse Keating 2006-07-17 09:54:17 EDT
Will there not be a broken dep then, gimp-devel on gimp?  I can exlude a
package, but I'd much rather not have broken deps in the system.  I'm not
comfortable with that.
Comment 7 Nils Philippsen 2006-07-17 09:58:46 EDT
Jesse, it's both 32bit gimp-devel and 32bit gimp that should be excluded, see
above why. Up to FC5, only 64bit versions of these packages have been present,
with no broken deps that I know of.
Comment 8 Bill Nottingham 2006-07-17 10:59:06 EDT
If we can't, rather than split off the docs, splitting off the gimp libs would
probably be simpler.
Comment 9 Nils Philippsen 2006-07-17 11:32:24 EDT
Hmm, it's probably not only the docs, but the binaries as well (e.g.
/usr/bin/gimp-2.2). While we could work around the multilib problem by splitting
off libraries, I think there shouldn't be a multilib problem at all -- gimp, its
libraries and accompanying devel files should only be present for one architecture.
Comment 10 Jesse Keating 2006-07-17 12:17:24 EDT
In a multi-lib env, the base arch is preferred for the bin files
(/usr/bin/gimp-2.2), the devel packages would be the same, and you'd get lib and
lib64 versions of the libraries.

What if you wanted to build 32bit plugins on your 64bit box?  Thats WHY we
provide multilib.
Comment 11 Nils Philippsen 2006-07-18 07:51:56 EDT
Hmm, I had the impression that we provided multilib so people could run 3rd
party 32bit software on their 64bit systems. I haven't heard yet that we support
building 32bit software on 64bit without using a 32bit buildroot -- at least we
haven't done so in the past (beehive) and brew won't be much different I presume.
Comment 12 Jesse Keating 2006-07-18 08:18:38 EDT
Our build system doesn't support it, but we support it for our users when they
install the system.
Comment 13 Nils Philippsen 2006-07-18 09:27:00 EDT
Hmm, I wasn't aware of that (and couldn't find any statements on it on the
various websites), but if that's how we want to spend space on the media... ;-).
Anyway, I'll only include the gimptool for the "primary" architecture, if people
want to build for the secondary one, they'll have to use pkg-config instead.

Note You need to log in before you can comment on or make changes to this bug.