Bug 19887 - /etc/rc.d/init.d/sendmail restart often doesn't
/etc/rc.d/init.d/sendmail restart often doesn't
Status: CLOSED DUPLICATE of bug 20696
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-26 18:48 EDT by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-08 16:43:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-26 18:48:41 EDT
Running /etc/rc.d/init.d/sendmail restart tends to leave the sendmail
daemon down.

The redhat rc daemon() function checks to see if any processes with the
daemon's name exist, and if so, will not start the daemon.  For sendmail,
this is a bad idea, as there are often queue jobs still running when the
main daemon exits.

More generally, this behavior of daemon() is questionable.  There are
probably other daemons out there that behave like this.
Comment 1 John Hardin 2000-11-08 16:43:09 EST
This problem still exists in 6.2
"sendmail start" should probably wait a bit (15 sec) for queues to complete, and
then start blowing them away.
Comment 2 Bill Nottingham 2000-11-13 01:25:30 EST

*** This bug has been marked as a duplicate of 20696 ***

Note You need to log in before you can comment on or make changes to this bug.