Bug 198919 - gwget fails to build in mock with minimal build environment.
gwget fails to build in mock with minimal build environment.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gwget (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-BuildReq
  Show dependency treegraph
 
Reported: 2006-07-14 12:21 EDT by Paul Howarth
Modified: 2013-01-09 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-15 10:30:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log with minimal environment (1.25 KB, text/plain)
2006-07-14 12:21 EDT, Paul Howarth
no flags Details
Patch updating gwget's configure script and spec to allow builds against epiphany 2.15 (2.65 KB, patch)
2006-07-14 12:23 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Paul Howarth 2006-07-14 12:21:42 EDT
This package fails to build in mock if the minimal build group is reduced to
only the packages listed in the Exceptions section of the packaging guidelines.
 build.log is attached.

There are a couple of reasons for this.

Firstly, additional buildreqs of automake and libtool are needed. The existing
buildreq of autoconf can be removed if these are added, since automake depends
on autoconf.

Secondly, rawhide now has epiphany 2.15, and the existing patch to the configure
script only updates it for detection of epiphany 2.14. I shall attach an
additional patch that enables the package to build against epiphany 2.15.
Comment 1 Paul Howarth 2006-07-14 12:21:43 EDT
Created attachment 132448 [details]
Build log with minimal environment
Comment 2 Paul Howarth 2006-07-14 12:23:43 EDT
Created attachment 132449 [details]
Patch updating gwget's configure script and spec to allow builds against epiphany 2.15
Comment 3 Christoph Wickert 2006-07-15 09:34:31 EDT
Thanks for looking at this, Paul.

I wanted to update to 0.98.1 anyway (which makes the epiphany patches
superflurious), but I'm going to publish an updated 0.97-5 release to fix the
BRs first. This will also fix the upgrade path which is broken ATM. 0.98.1 has
some issues with bonobo and libnotiy under rawhide, which need some more attention.

Note You need to log in before you can comment on or make changes to this bug.