Bug 1989402 - Tests required internet access failing in disconnected environments
Summary: Tests required internet access failing in disconnected environments
Keywords:
Status: MODIFIED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Test Infrastructure
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Arda Guclu
QA Contact:
URL:
Whiteboard:
Depends On: 1957193
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-03 07:10 UTC by Arda Guclu
Modified: 2021-09-10 17:06 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 26369 0 None None None 2021-08-03 07:23:49 UTC

Description Arda Guclu 2021-08-03 07:10:55 UTC
Description of problem:

[sig-devex] check registry.redhat.io is available and samples operator can import sample imagestreams run sample related validations
[sig-devex][Feature:Templates] templateinstance readiness test  should report failed soon after an annotated objects has failed
[sig-devex][Feature:Templates] templateinstance readiness test  should report ready soon after all annotated objects are ready
[sig-network] Networking should provide Internet connection for containers

tests are failing in disconnected environment since they require to internet access. 

For example, sig-devex tests try to pull ruby image.

Steps to Reproduce:
1. Run e2e-metal-ipi-ovn-ipv6 job by enabling these tests 
2. Tests are failing
3.

Actual results:
Tests are running and failing with image pull error

Expected results:
Tests should be skipped for disconnected environment


Note You need to log in before you can comment on or make changes to this bug.