Bug 1989648 - [release-4.7] vSphere Machines stuck in deleting phase if associated Node object is deleted
Summary: [release-4.7] vSphere Machines stuck in deleting phase if associated Node obj...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.z
Assignee: dmoiseev
QA Contact: sunzhaohua
URL:
Whiteboard:
: 1977637 (view as bug list)
Depends On: 1977634
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-03 16:23 UTC by OpenShift BugZilla Robot
Modified: 2021-09-21 22:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-21 22:32:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 895 0 None None None 2021-08-16 10:46:41 UTC
Red Hat Product Errata RHBA-2021:3510 0 None None None 2021-09-21 22:33:17 UTC

Comment 2 Joel Speed 2021-08-19 10:23:36 UTC
*** Bug 1977637 has been marked as a duplicate of this bug. ***

Comment 5 sunzhaohua 2021-09-13 07:32:13 UTC
verified
clusterversion: 4.7.0-0.nightly-2021-09-10-001829

 oc get machineset
NAME                    DESIRED   CURRENT   READY   AVAILABLE   AGE
zhsun472-tzfm2-worker   2         2         2       2           77m
$ oc get node
NAME                          STATUS   ROLES    AGE   VERSION
zhsun472-tzfm2-master-0       Ready    master   76m   v1.20.0+9689d22
zhsun472-tzfm2-master-1       Ready    master   76m   v1.20.0+9689d22
zhsun472-tzfm2-master-2       Ready    master   76m   v1.20.0+9689d22
zhsun472-tzfm2-worker-nznd9   Ready    worker   67m   v1.20.0+9689d22
zhsun472-tzfm2-worker-r76c4   Ready    worker   67m   v1.20.0+9689d22

$ oc delete node zhsun472-tzfm2-worker-r76c4
node "zhsun472-tzfm2-worker-r76c4" deleted
$ oc get machine
NAME                          PHASE     TYPE   REGION   ZONE   AGE
zhsun472-tzfm2-master-0       Running                          80m
zhsun472-tzfm2-master-1       Running                          80m
zhsun472-tzfm2-master-2       Running                          80m
zhsun472-tzfm2-worker-7kdqt   Running                          3m1s
zhsun472-tzfm2-worker-nznd9   Running                          76m

Comment 8 errata-xmlrpc 2021-09-21 22:32:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.31 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3510


Note You need to log in before you can comment on or make changes to this bug.