Bug 19897 - gnupg is not suid-root
Summary: gnupg is not suid-root
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnupg (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 51913 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-27 04:00 UTC by Bradley
Modified: 2007-04-18 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 22:46:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bradley 2000-10-27 04:00:38 UTC
The latest errata gnupg (gnupg-1.0.4-4.6.x), is not suid. gnupg should be
suid so that mlock will work.

Currently, it displays an annoying: "gpg: Warning: using insecure memory!"
error whenever its run. (I know I can turn this off with an option, but its
not the default)

Comment 1 Nalin Dahyabhai 2000-10-30 20:57:12 UTC
This is done on purpose in an attempt to reduce the number of setuid
applications on the system.  When the kernel offers capabilities, we'll revisit
this.

Comment 2 Nalin Dahyabhai 2002-01-18 18:10:49 UTC
*** Bug 51913 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2002-01-18 21:43:42 UTC
*** Bug 51913 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.