Bug 1989798 - yaml multi file dnd duplicates previous dragged files
Summary: yaml multi file dnd duplicates previous dragged files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.0
Assignee: Joe Caiani
QA Contact: Siva Reddy
URL:
Whiteboard:
Depends On: 1986502
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-04 03:21 UTC by OpenShift BugZilla Robot
Modified: 2021-11-10 21:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-10 21:01:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10131 0 None open [release-4.9] Bug 1989798: Fix state bug to eliminate duplicates in dragged files 2021-09-24 19:42:03 UTC
Github openshift console pull 9718 0 None None None 2021-08-06 15:15:54 UTC
Red Hat Product Errata RHBA-2021:4119 0 None None None 2021-11-10 21:01:46 UTC

Description OpenShift BugZilla Robot 2021-08-04 03:21:29 UTC
+++ This bug was initially created as a clone of Bug #1986502 +++

Description of problem:

Dragging and dropping files into the yaml editor can enter a bad state where subsequent additions result in unexpected content.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create 2 yaml files on your local system
2. go to the import yaml form (click the + icon in the masthead)
3. drag the first file into the yaml editor
4. delete the contents of the yaml form
5. drag the second file into the yaml editor

Actual results:
After dragging the second file into the form, the contents of both the first and second file appears.

Expected results:
Only the second file contents should be present because all contents in the form was deleted prior to adding the second file


Additional info:

Comment 3 Yadan Pei 2021-08-17 07:08:15 UTC
Assign it back since the primary bug also failed validation, see https://bugzilla.redhat.com/show_bug.cgi?id=1986502#c3

Comment 4 ximhan 2021-08-20 07:26:57 UTC
OpenShift engineering has decided to NOT ship 4.8.6 on 8/23 due to the following issue.
https://bugzilla.redhat.com/show_bug.cgi?id=1995785
All the fixes part will be now included in 4.8.7 on 8/30.

Comment 8 Yadan Pei 2021-11-01 07:56:30 UTC
PR #9718 is backport PR to 4.8 and the PR for 4.9 fix has been verified prior merge, moving to VERIFIED directly

Comment 11 errata-xmlrpc 2021-11-10 21:01:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4119


Note You need to log in before you can comment on or make changes to this bug.