Bug 198985 - gnome-screensaver uses 100% cpu when blanking screen, making current drawn go up!
gnome-screensaver uses 100% cpu when blanking screen, making current drawn go...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-07-15 07:16 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 16:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file with the debug output (12.84 KB, text/plain)
2006-07-25 14:00 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2006-07-15 07:16:39 EDT
1 week old rawhide system, x86_64.

When i leave my Pc, first the screensaver kicks in and my system gets
significantly louder (cpu can do speedstepping and steps up, fans go faster to
keep it cool). AFAIK it never did this when I was using xscreensaver, but with
it being a CPU (and energy/power) hog while screensaving OK, now after a while
(10 minutes I think) it stops screensaving and blanks the screen, yet my system
stays loud / noisy. Only when I exit the blanked screen it gets normal again. My
cpu monitor graphs conform this, while gnome-screensaver is saving / blanking
100% cpu gets used.
Comment 1 Matthias Clasen 2006-07-25 12:20:24 EDT
Should file this upstream, too. But maybe William is watching anyway....
hi William !
Comment 2 jmccann 2006-07-25 12:42:28 EDT
Hi :)

I can't reproduce this with HEAD gnome-screensaver and gnome-power-manager. 
What version numbers are you using for each?

Here's a way to test this:

% pkill gnome-screenaver
% gnome-screensaver --no-daemon --debug

[in another terminal]
% gnome-screensaver-command --activate; \
sleep 5; \
dbus-send --session --dest=org.gnome.PowerManager \
/org/gnome/PowerManager org.gnome.PowerManager.SetDpmsMode string:suspend

Look for messages in the debug log regarding "throttle status" and
starting/stopping jobs.  Please post those messages with the context here.  Thanks.
Comment 3 Hans de Goede 2006-07-25 13:21:17 EDT
Erm, I'm not suspending. This is on a desktop with a powernow processor, which
is my development machine and often is busy building packages, thus I don't want
it to suspend when I'm away from the console. Also I don't even know if suspend
works on this machine.

Even when not suspending gnome-screensaver shoud not push my CPU to its max. Its
annoying, it makes my PC noticable louder when I'm in the same room and pushes
up my energy bill for no good reason.

Comment 4 jmccann 2006-07-25 13:27:20 EDT
So, is this bug that the screensaver theme is using CPU even when DPMS has
suspended the monitor or simply that when DPMS has not kicked in that the theme
uses too much CPU?

If it is the former then please try what I mentioned in comment #2.  If it is
the latter then:
a) select "Blank screen" as your screensaver theme from the preferences dialog
b) submit a bug for the screensaver theme is using 100% CPU
Comment 5 Hans de Goede 2006-07-25 13:33:12 EDT
I don't know if DPMS has kicked in, but my monitor has gone blank, so I assume
it has, is that correct?
Comment 6 jmccann 2006-07-25 13:38:01 EDT
Most likely.  If you want to check you can run "dbus-monitor --session" lock the
screen and wait.  Then look back at the output of the monitor command.

Please try what is posted in comment #2.  Thanks.
Comment 7 Hans de Goede 2006-07-25 14:00:40 EDT
Created attachment 133006 [details]
log file with the debug output

Here is a log file with the requested debug output, but I don't think this is
what you want, the screen didn't even go blank after 5 seconds.

After waiting 10 seconds I found a new bug, you cannot exit the screensaver
with the ESC ket when it requires a password. The password box flashes on
screen and then immediatly disappears (presumably because of the ESC key being
pressed). I should file a new bug for this I assume?
Comment 8 P Jones 2007-03-12 13:32:28 EDT
I'm seeing the 100% CPU thing on an FC6 Asus M2Ne laptop. It runs the CPU at
100% for so long that the laptop actually goes into what I assume is thermal
protection mode and locks up (documentation for this "feature" is sparse).
Comment 9 P Jones 2007-03-12 13:33:37 EDT
Sorry for a lack of useful information in my last comment.

rpm -qa gnome-screensaver yields: gnome-screensaver-2.16.1-4.fc6
Comment 10 Ray Strode [halfline] 2007-03-28 14:43:55 EDT
Are you guys still hitting this?
Comment 11 Hans de Goede 2007-03-28 15:22:50 EDT
Okay, I've done some testing, observations:
1) I've tried running all the gnome-screensaver "builtin" screensavers, all but
   these 3: floating xxx. pictures folder, pop art squares have 100% cpu usage.
   BAD !!!! I've ported many simple 2D games from other OS to linux, and with
   one well aimed usleep in the main loop managed to get them running with the
   lowest speed step of my CPU, someone please hit the author off these savers
   with a cluestick!
2) Next I installed xscreensaver-extras-gss, randomly selected a few off the new
   screensavers and none used any significant amount of CPU, maybe we should
   replace those builtin to gnome-screensaver with those from xscreensaver?
3) Pressing the power management button in the screensaver dialog does nothing!
4) The commands from comment 2 activate my screensaver, but do nothing after 
   that. (probably related to 3) Notice that I'm not running 
   gnome-power-manager, my install/homedir predates gnome-power-manager and 
   gnome-power-manager has never been added to my session.
5) I can reproduce the scenario my original problem by doing the following:
   gnome-screensaver-command --activate && sleep 5 && xset dpms force suspend
6) Good news, when doing 5 and the screen suspends I no longer have 100% cpu 
   usage.
7) And I can fully reproduce my original problem (including 100% cpu load when 
   blanking) by doing:
   gnome-screensaver-command --activate && sleep 5 && xset dpms force standby
Comment 12 Ray Strode [halfline] 2007-03-28 15:35:59 EDT
so by default we only ship:

Cosmos
Floating Fedora Bubbles
Floating Feet
Pictures Folder
Pop art squares

So is the 100% cpu problem you're talking about only Cosmos?  If you choose one
the screensavers that does not use 100% by default and do your command from 7,
do you get 100% cpu load?
Comment 13 Hans de Goede 2007-03-28 15:53:12 EDT
(In reply to comment #12)
> so by default we only ship:
> 
> Cosmos
> Floating Fedora Bubbles
> Floating Feet
> Pictures Folder
> Pop art squares
> 
> So is the 100% cpu problem you're talking about only Cosmos?
My bad, cosmos is fine, I see now that all the 100% cpu mister meaners are all
from: rss-glx-gnome-screensaver

> If you choose one
> the screensavers that does not use 100% by default and do your command from 7,
> do you get 100% cpu load?

No.

So I guess that only leaves:
3) Pressing the power management button in the screensaver dialog does nothing!
which I guess would be best filed under a new bug (the capplet should detect if
gnome-power-manager is running and if it isn't not show the button).

Comment 14 Ray Strode [halfline] 2007-03-28 16:00:36 EDT
Sounds good. When you file the report, can post a link to it here?
Comment 15 Hans de Goede 2007-03-29 08:50:43 EDT
As requested, the power management button not doing anything is here: bug 234453

Note You need to log in before you can comment on or make changes to this bug.