Bug 198999 - snmp backend doesn't find JetDirect-attached HP Officejet 7310
snmp backend doesn't find JetDirect-attached HP Officejet 7310
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-07-15 11:06 EDT by John Bunch
Modified: 2009-11-18 22:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 05:12:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2151 None None None Never

  None (edit)
Description John Bunch 2006-07-15 11:06:24 EDT
Description of problem:
When configuring the Officejet 7310 All-in-One via system-config-printer, its
type is not automatically detected.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-33.3

How reproducible:
Always.

Steps to Reproduce:
1.  Cable the Officejet 7310 All-in-One via Ethernet.
2.  # system-config-printer
3.  In the Printer configuration window, click "New".
4.  In the Add a new print queue window, click "Forward".
5.  In the Queue name window, click "Forward".
6.  In the Queue type window, at Select a queue type, select Networked JetDirect
from the dropdown.
7.  Still in the Queue type window, enter "turtledove" for the printer's network
name, which resolves to its IP address via DNS.
8.  Still in the Queue type window, click "Forward".

Actual results:
In the Printer model window, the drop down defaults to "Generic".

Expected results:
In the Printer model window, the drop down should default to a manufacturer of
"HP", and the model should default to OfficeJet 7300.

Additional info:
Comment 1 Tim Waugh 2006-12-07 06:57:07 EST
Please show me the output of '/usr/sbin/lpinfo -l -v'.  Thanks.
Comment 2 John Bunch 2006-12-09 09:04:23 EST
Output of '/usr/sbin/lpinfo -l -v':
-------------Cut here---------------------
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
Device: uri = hal
        class = direct
        info = Hal printing backend
        make-and-model = Unknown
        device-id = 
Device: uri = hp:/no_device_found
        class = direct
        info = hp no_device_found
        make-and-model = Unknown
        device-id = 
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
Device: uri = parallel:/dev/lp0
        class = direct
        info = LPT #1
        make-and-model = Unknown
        device-id = 
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS1?baud=115200
        class = serial
        info = Serial Port #2
        make-and-model = Unknown
        device-id = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
[bunch@bunch ~]$ /usr/sbin/lpinfo -l -v
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
Device: uri = hal
        class = direct
        info = Hal printing backend
        make-and-model = Unknown
        device-id = 
Device: uri = hp:/no_device_found
        class = direct
        info = hp no_device_found
        make-and-model = Unknown
        device-id = 
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
Device: uri = parallel:/dev/lp0
        class = direct
        info = LPT #1
        make-and-model = Unknown
        device-id = 
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS1?baud=115200
        class = serial
        info = Serial Port #2
        make-and-model = Unknown
        device-id = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
--------------------Cut here----------------------
The printer is currently connected as a JetDirect printer, since it has an
Ethernet port.  If you would also like to see output while connected via USB,
please ask and I will wire it that way for you.  Thank you.
Comment 3 Tim Waugh 2006-12-11 08:44:19 EST
What does '/usr/lib/cups/backend/snmp turtledove' say?

Yes, I would also like to see the 'lpinfo -l -v' output when it is connected via
USB if that's alright.  Thanks.
Comment 4 John Bunch 2006-12-11 19:37:24 EST
Here is the SNMP output:
[bunch@bunch ~]$ /usr/lib/cups/backend/snmp turtledove
INFO: Using default SNMP Community public
network socket://192.168.0.4 "Officejet 7300 series" "Officejet 7300 series
192.168.0.4" ""

Here is the output of lpinfo with both a USB and network connection to the
OfficeJet 7310:
[bunch@bunch ~]$ /usr/sbin/lpinfo -l -v
Device: uri =
hal:///org/freedesktop/Hal/devices/usb_device_3f0_4211_MY64PQ853B04HR_if1_printer_MY64PQ853B04HR
        class = direct
        info = 6543
        make-and-model = HP Officejet 7300 series
        device-id = 
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
Device: uri = usb://HP/Officejet%207300%20series?serial=MY64PQ853B04HR
        class = direct
        info = HP Officejet 7300 series USB #1
        make-and-model = HP Officejet 7300 series
        device-id = MFG:HP;MDL:Officejet 7300
series;CMD:MLC,PCL,PML,DW-PCL,DESKJET,DYN;1284.4DL:4d,4e,1;CLS:PRINTER;DES:6543;SN:MY64PQ853B04HR;S:038080C484001021002c180003dc2880043;J:
                  
;Z:0102,0503d549014dc9,0600;BT:000000000000,4F66666963656A6574203733303020736572696573,0000008F,60;
Device: uri = hp:/usb/Officejet_7300_series?serial=MY64PQ853B04HR
        class = direct
        info = HP Officejet 7300 series USB MY64PQ853B04HR HPLIP
        make-and-model = HP Officejet 7300 series
        device-id = MFG:HP;MDL:Officejet 7300 series;CLS:PRINTER;DES:Officejet
7300 series;SN:MY64PQ853B04HR;
Device: uri = hpfax:/usb/Officejet_7300_series?serial=MY64PQ853B04HR
        class = direct
        info = HP Officejet 7300 series USB MY64PQ853B04HR HPLIP HP Fax
        make-and-model = HP Fax
        device-id = MFG:HP;MDL:Fax;DES:HP Fax;
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
Device: uri = parallel:/dev/lp0
        class = direct
        info = LPT #1
        make-and-model = Unknown
        device-id = 
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS0?baud=115200
        class = serial
        info = Serial Port #1
        make-and-model = Unknown
        device-id = 
Device: uri = serial:/dev/ttyS1?baud=115200
        class = serial
        info = Serial Port #2
        make-and-model = Unknown
        device-id = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 

Just let me know if you need anything else.  Thank you.
Comment 5 Tim Waugh 2006-12-12 05:51:17 EST
Four things wrong here:

1. The snmp backend isn't reporting your printer in the broadcast results, but
that is potentially a problem on the device end

2. The snmp backend doesn't report the manufacturer, only the model name, when
pointed at the IP address of the device

3. system-config-printer doesn't try running the snmp backend with the IP
address specified when adding a new JetDirect-type queue, and it probably
should.  I've filed bug #219264 to track that.

4. foomatic didn't have the IEEE 1284 Device ID information correct for this
model.  I have fixed that upstream.

Changing component.
Comment 6 Tim Waugh 2006-12-12 05:52:26 EST
What does 'rpm -q cups' say?

I'd also like to see the output of:
  CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp turtledove
Comment 7 John Bunch 2006-12-12 17:39:26 EST
Here it is:
[bunch@bunch ~]$ rpm -q cups
cups-1.2.4-9
[bunch@bunch ~]$ CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp turtledove
INFO: Using default SNMP Community public
DEBUG: Scanning for devices in "public" via "turtledove"...
DEBUG: 0.000 Sending 46 bytes to 192.168.0.4...
DEBUG: SEQUENCE 44 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Request-PDU 31 bytes
DEBUG:         INTEGER 4 bytes 1165963036
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 17 bytes
DEBUG:             SEQUENCE 15 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.2.1
DEBUG:                 NULL VALUE 0 bytes
DEBUG: Hex dump of packet:
DEBUG: 0000  30 2C 02 01 00 04 06 70 75 62 6C 69 63 A0 1F 02
DEBUG: 0010  04 45 7F 2F 1C 02 01 00 02 01 00 30 11 30 0F 06
DEBUG: 0020  0B 2B 06 01 02 01 19 03 02 01 02 01 05 00
DEBUG: 0.005 Received 63 bytes from 192.168.0.4...
DEBUG: community="public"
DEBUG: request-id=1165963036
DEBUG: error-status=0
DEBUG: SEQUENCE 59 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Response-PDU 44 bytes
DEBUG:         INTEGER 4 bytes 1165963036
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 28 bytes
DEBUG:             SEQUENCE 24 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.2.1
DEBUG:                 OID 9 bytes .1.3.6.1.2.1.25.3.1.5
DEBUG: Hex dump of packet:
DEBUG: 0000  30 82 00 3B 02 01 00 04 06 70 75 62 6C 69 63 A2
DEBUG: 0010  82 00 2C 02 04 45 7F 2F 1C 02 01 00 02 01 00 30
DEBUG: 0020  82 00 1C 30 82 00 18 06 0B 2B 06 01 02 01 19 03
DEBUG: 0030  02 01 02 01 06 09 2B 06 01 02 01 19 03 01 05
DEBUG: add_cache(addr=0xbfe4b2d8, addrname="192.168.0.4", uri="(null)",
id="(null)", make_and_model="(null)")
DEBUG: 0.005 Sending 46 bytes to 192.168.0.4...
DEBUG: SEQUENCE 44 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Request-PDU 31 bytes
DEBUG:         INTEGER 4 bytes 1165963037
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 17 bytes
DEBUG:             SEQUENCE 15 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.3.1
DEBUG:                 NULL VALUE 0 bytes
DEBUG: Hex dump of packet:
DEBUG: 0000  30 2C 02 01 00 04 06 70 75 62 6C 69 63 A0 1F 02
DEBUG: 0010  04 45 7F 2F 1D 02 01 00 02 01 00 30 11 30 0F 06
DEBUG: 0020  0B 2B 06 01 02 01 19 03 02 01 03 01 05 00
DEBUG: 0.012 Received 75 bytes from 192.168.0.4...
DEBUG: community="public"
DEBUG: request-id=1165963037
DEBUG: error-status=0
DEBUG: SEQUENCE 71 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Response-PDU 56 bytes
DEBUG:         INTEGER 4 bytes 1165963037
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 40 bytes
DEBUG:             SEQUENCE 36 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.3.1
DEBUG:                 OCTET STRING 21 bytes "Officejet 7300 series"
DEBUG: Hex dump of packet:
DEBUG: 0000  30 82 00 47 02 01 00 04 06 70 75 62 6C 69 63 A2
DEBUG: 0010  82 00 38 02 04 45 7F 2F 1D 02 01 00 02 01 00 30
DEBUG: 0020  82 00 28 30 82 00 24 06 0B 2B 06 01 02 01 19 03
DEBUG: 0030  02 01 03 01 04 15 4F 66 66 69 63 65 6A 65 74 20
DEBUG: 0040  37 33 30 30 20 73 65 72 69 65 73
DEBUG: 1.011 Probing 192.168.0.4...
DEBUG: 1.015 POST /ipp...
DEBUG: 1.015 ipp://192.168.0.4:631/ipp server-error-device-error (Unable to
reconnect)
DEBUG: 1.015 POST /ipp/port2...
DEBUG: 1.015 ipp://192.168.0.4:631/ipp/port2 server-error-device-error (Unable
to reconnect)
DEBUG: 1.015 POST /ipp/port3...
DEBUG: 1.015 ipp://192.168.0.4:631/ipp/port3 server-error-device-error (Unable
to reconnect)
DEBUG: 1.015 POST /EPSON_IPP_Printer...
DEBUG: 1.015 ipp://192.168.0.4:631/EPSON_IPP_Printer server-error-device-error
(Unable to reconnect)
DEBUG: 1.015 POST /LPT1...
DEBUG: 1.015 ipp://192.168.0.4:631/LPT1 server-error-device-error (Unable to
reconnect)
DEBUG: 1.016 POST /LPT2...
DEBUG: 1.016 ipp://192.168.0.4:631/LPT2 server-error-device-error (Unable to
reconnect)
DEBUG: 1.016 POST /COM1...
DEBUG: 1.016 ipp://192.168.0.4:631/COM1 server-error-device-error (Unable to
reconnect)
DEBUG: 1.016 POST /...
DEBUG: 1.016 ipp://192.168.0.4:631/ server-error-device-error (Unable to reconnect)
DEBUG: 1.016 Trying socket://192.168.0.4:9100...
DEBUG: 192.168.0.4 supports AppSocket!
network socket://192.168.0.4 "Officejet 7300 series" "Officejet 7300 series
192.168.0.4" ""
DEBUG: 1.016 Scan complete!
Comment 8 Tim Waugh 2006-12-13 06:19:58 EST
Changing version to 'fc6' since cups-1.2.4-9 is what shipped in FC-6 final.

First: please apply the updates (e.g. with 'yum update').  Now, after having
applying them, what does the output of 'CUPS_DEBUG_LEVEL=3
/usr/lib/cups/backend/snmp turtledove' say?
Comment 9 John Bunch 2006-12-13 22:18:48 EST
[bunch@bunch ~]$ CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp turtledove
INFO: Using default SNMP Community public
DEBUG: Scanning for devices in "public" via "turtledove"...
DEBUG: 0.001 Sending 46 bytes to 192.168.0.4...
DEBUG: SEQUENCE 44 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Request-PDU 31 bytes
DEBUG:         INTEGER 4 bytes 1166066258
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 17 bytes
DEBUG:             SEQUENCE 15 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.2.1
DEBUG:                 NULL VALUE 0 bytes
DEBUG: Hex dump of packet:
DEBUG: 0000  30 2C 02 01 00 04 06 70 75 62 6C 69 63 A0 1F 02
DEBUG: 0010  04 45 80 C2 52 02 01 00 02 01 00 30 11 30 0F 06
DEBUG: 0020  0B 2B 06 01 02 01 19 03 02 01 02 01 05 00
DEBUG: 0.008 Received 63 bytes from 192.168.0.4...
DEBUG: community="public"
DEBUG: request-id=1166066258
DEBUG: error-status=0
DEBUG: SEQUENCE 59 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Response-PDU 44 bytes
DEBUG:         INTEGER 4 bytes 1166066258
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 28 bytes
DEBUG:             SEQUENCE 24 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.2.1
DEBUG:                 OID 9 bytes .1.3.6.1.2.1.25.3.1.5
DEBUG: Hex dump of packet:
DEBUG: 0000  30 82 00 3B 02 01 00 04 06 70 75 62 6C 69 63 A2
DEBUG: 0010  82 00 2C 02 04 45 80 C2 52 02 01 00 02 01 00 30
DEBUG: 0020  82 00 1C 30 82 00 18 06 0B 2B 06 01 02 01 19 03
DEBUG: 0030  02 01 02 01 06 09 2B 06 01 02 01 19 03 01 05
DEBUG: add_cache(addr=0xbfe7b388, addrname="192.168.0.4", uri="(null)",
id="(null)", make_and_model="(null)")
DEBUG: 0.010 Sending 46 bytes to 192.168.0.4...
DEBUG: SEQUENCE 44 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Request-PDU 31 bytes
DEBUG:         INTEGER 4 bytes 1166066259
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 17 bytes
DEBUG:             SEQUENCE 15 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.3.1
DEBUG:                 NULL VALUE 0 bytes
DEBUG: Hex dump of packet:
DEBUG: 0000  30 2C 02 01 00 04 06 70 75 62 6C 69 63 A0 1F 02
DEBUG: 0010  04 45 80 C2 53 02 01 00 02 01 00 30 11 30 0F 06
DEBUG: 0020  0B 2B 06 01 02 01 19 03 02 01 03 01 05 00
DEBUG: 0.015 Received 75 bytes from 192.168.0.4...
DEBUG: community="public"
DEBUG: request-id=1166066259
DEBUG: error-status=0
DEBUG: SEQUENCE 71 bytes
DEBUG:     INTEGER 1 bytes 0
DEBUG:     OCTET STRING 6 bytes "public"
DEBUG:     Get-Response-PDU 56 bytes
DEBUG:         INTEGER 4 bytes 1166066259
DEBUG:         INTEGER 1 bytes 0
DEBUG:         INTEGER 1 bytes 0
DEBUG:         SEQUENCE 40 bytes
DEBUG:             SEQUENCE 36 bytes
DEBUG:                 OID 11 bytes .1.3.6.1.2.1.25.3.2.1.3.1
DEBUG:                 OCTET STRING 21 bytes "Officejet 7300 series"
DEBUG: Hex dump of packet:
DEBUG: 0000  30 82 00 47 02 01 00 04 06 70 75 62 6C 69 63 A2
DEBUG: 0010  82 00 38 02 04 45 80 C2 53 02 01 00 02 01 00 30
DEBUG: 0020  82 00 28 30 82 00 24 06 0B 2B 06 01 02 01 19 03
DEBUG: 0030  02 01 03 01 04 15 4F 66 66 69 63 65 6A 65 74 20
DEBUG: 0040  37 33 30 30 20 73 65 72 69 65 73
DEBUG: 1.019 Probing 192.168.0.4...
DEBUG: 1.023 Trying socket://192.168.0.4:9100...
DEBUG: 192.168.0.4 supports AppSocket!
network socket://192.168.0.4 "Officejet 7300 series" "Officejet 7300 series
192.168.0.4" ""
DEBUG: 1.024 Scan complete!
Comment 10 Tim Waugh 2006-12-14 05:45:07 EST
Thanks.  Just to check, what does 'rpm -q cups' say now?
Comment 11 John Bunch 2006-12-14 17:26:06 EST
[bunch@bunch ~]$ rpm -q cups
cups-1.2.4-9
cups-1.2.7-1.3.fc6
Comment 12 Tim Waugh 2006-12-15 05:12:16 EST
Reported upstream.
Comment 13 Fedora Update System 2007-01-17 11:27:56 EST
Fixed in update: foomatic-3.0.2-39.4.fc6

Note You need to log in before you can comment on or make changes to this bug.