Bug 199030 - top still sigabrt on the fb console
top still sigabrt on the fb console
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 22:52 EDT by james
Modified: 2008-03-12 02:10 EDT (History)
0 users

See Also:
Fixed In Version: 3.2.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 02:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace output (112.21 KB, text/plain)
2006-09-22 15:26 EDT, james
no flags Details

  None (edit)
Description james 2006-07-15 22:52:05 EDT
Description of problem:
The previous version of top seemed to sigabrt on both Konsole and the text
console.  I upgraded.  Now, top seems to run ok on Konsole with X, but still
sigabrt's on my fb text console.  I have not checked it on the character-mode
console.


Version-Release number of selected component (if applicable):
procps-3.2.6-3.5

How reproducible:
every time

Steps to Reproduce:
1. run top on the fb console


Additional info:
Here is the end of an strace:
3487  open("/proc/loadavg", O_RDONLY)   = 4
3487  lseek(4, 0, SEEK_SET)             = 0
3487  read(4, "0.18 0.39 0.29 2/140 3487\n", 1023) = 26
3487  open("/proc/stat", O_RDONLY)      = 5
3487  fstat64(5, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
3487  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0)
= 0xb7ff2000
3487  _llseek(5, 0, [0], SEEK_SET)      = 0
3487  read(5, "cpu  9079 1841 5713 326624 4923 "..., 1024) = 644
3487  open("/dev/tty", O_RDWR|O_NONBLOCK|O_NOCTTY) = 6
3487  writev(6, [{"*** stack smashing detected ***:"..., 33}, {"top", 3}, {"
terminated\n", 12}], 3) = 48
3487  rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
3487  write(1, "\33[H\33[J\33[22;23;24;25;27;10mtop - "..., 1243) = 1243
3487  gettid()                          = 3487
3487  tgkill(3487, 3487, SIGABRT)       = 0
3487  --- SIGABRT (Aborted) @ 0 (0) ---
3487  +++ killed by SIGABRT +++
Comment 1 Karel Zak 2006-09-19 07:32:34 EDT
I can't reproduce this problem. Please, provide more details:

 - # cat /proc/stat
 - # uname -a
 - complete strace from the top command.
Comment 2 james 2006-09-22 15:26:49 EDT
Created attachment 136967 [details]
strace output
Comment 3 james 2006-09-22 15:34:34 EDT
$ cat /proc/stat
cpu  19939 7188 5327 1151341 6299 4646 0 0
cpu0 19939 7188 5327 1151341 6299 4646 0 0
intr 4958146 2986670 1406 0 10 11 0 0 23 1 0 1628592 67785 749 0 30411 242488 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
ctxt 22315392
btime 1158940039
processes 3965
procs_running 1
procs_blocked 0

$ uname -a
Linux onyx 2.6.16-1.2133_FC5 #1 Tue Jun 6 00:52:14 EDT 2006 i686 athlon i386
GNU/Linux
Comment 4 Karel Zak 2006-09-27 09:55:10 EDT
It could be a problem with parsing information about CPUs (this part of the top
is not too much stable), but I can't help you if I can't reproduce this problem.
Maybe someone other will have same problem or you can try debug the top command.
Comment 5 Albert Cahalan 2006-12-25 16:19:49 EST
I found it. This will be fixed in the next release.

Don't panic. It's not controllable by some other user.
Comment 6 Karel Zak 2006-12-25 17:50:50 EST
(In reply to comment #5)
> I found it. This will be fixed in the next release.

Can you provide more details?
Comment 7 Tomas Smetana 2007-04-30 10:33:57 EDT
I've pushed version 3.2.7 to FC-5. If this solves the problem (nobody reports it
again) I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.