Bug 199033 - Unable to specify parity
Summary: Unable to specify parity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mdadm
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact:
URL:
Whiteboard:
: 197055 (view as bug list)
Depends On:
Blocks: 176344
TreeView+ depends on / blocked
 
Reported: 2006-07-16 04:29 UTC by John Newbigin
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0290
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-01 17:47:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix testing for an unset parity (layout) (653 bytes, patch)
2006-07-16 04:33 UTC, John Newbigin
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0290 0 normal SHIPPED_LIVE mdadm bug fix update 2007-05-01 17:45:47 UTC

Description John Newbigin 2006-07-16 04:29:19 UTC
Description of problem:
When using mdadm to create a RAID5 array, it is impossible to specify the parity
algorithm.


Version-Release number of selected component (if applicable):
mdadm-1.6.0-3

How reproducible:
Every time.

Steps to Reproduce:
1. You need some partitions or files setup with losetup
2. mdadm --create -l 5 -p la -n 3 /dev/md0 /dev/loop0 /dev/loop1 /dev/loop2
3. check the error message
  
Actual results:
mdadm: layout may only be sent once.  Second value was la


Expected results:
Create the RAID array.

Additional info:
This is a software bug which has been fixed in newer versions of mdadm.
In the RH version, the bug can be seen on line 444 of mdadm.c.  UnSet is a
constant but it is a positive number, to the test "layout >= 0" is always true.
 Updated mdadm changes the test to be "layout != UnSet" which works.

Comment 1 John Newbigin 2006-07-16 04:33:50 UTC
Created attachment 132520 [details]
Fix testing for an unset parity (layout)

Comment 2 Doug Ledford 2006-08-25 04:29:28 UTC

*** This bug has been marked as a duplicate of 197055 ***

Comment 3 John Newbigin 2006-08-27 23:33:59 UTC
But "You are not authorized to access bug #197055", so how would I ever know?

Comment 4 Doug Ledford 2006-08-28 00:02:35 UTC
It doesn't really say anything more than this one (I can't change the
permissions to allow you to see the other bug, or else I would).  Both reports
are legitimate and targetted for being fixed in the next update release.

Comment 5 Doug Ledford 2006-08-28 00:05:27 UTC
*** Bug 197055 has been marked as a duplicate of this bug. ***

Comment 6 John Newbigin 2006-08-28 00:09:41 UTC
Thanks for the feedback.

Comment 7 Daniel Riek 2006-08-28 22:17:41 UTC
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this request by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This request is not yet committed for inclusion in an Update release. 

Comment 10 Doug Ledford 2007-01-31 19:24:08 UTC
We are updating mdadm to 1.12.0 for RHEL4.5 and that update solves this problem.

Comment 14 Red Hat Bugzilla 2007-05-01 17:47:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0290.html


Comment 15 Issue Tracker 2007-06-11 10:20:02 UTC
Customer has been notified by the errata.

Thanks!

Internal Status set to 'Resolved'
Status set to: Closed by Tech
Resolution set to: 'RHEL 4.5'

This event sent from IssueTracker by lmacchia 
 issue 96717


Note You need to log in before you can comment on or make changes to this bug.